"Could not complete the iTunes Store request."

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Vagcmyevad, Jun 30, 2007.

  1. Vagcmyevad macrumors newbie

    Joined:
    Aug 23, 2002
    #1
    I'm having a problem where I can't even get into the iTunes store to activate my phone! See attached image...

    Anyone else getting this? :(
     

    Attached Files:

  2. gerafez macrumors newbie

    Joined:
    Jul 3, 2007
    #2
    Me too!

    I've been getting this error since yesterday morning and also cant activate my iPhone! Have you found a solution to this, or found a different way to activate your phone?
     
  3. fastdrive macrumors member

    Joined:
    Sep 28, 2006
    #3
    What OS and browser are you using?

    I had the same issues with my xp computer and IE7.

    Tried with my mac and safari and had no problems.

    It might be a browswer issue of some sort.
     
  4. gerafez macrumors newbie

    Joined:
    Jul 3, 2007
    #4
    i'm using mac osx 4.10 & iTunes 7.3

    i don't see how my internet browser might be a problem, i believe the activation process is all done through iTunes.

    but i have firefox set as my default, and can use safari if necessary.
     
  5. mittles macrumors newbie

    Joined:
    Jul 3, 2006
    #5
    I had the same issue - Here is how I fixed it

    Hold the sleep button + the menu button for 10 sec, wait until the Apple logo comes up and let the phone start then plug it into the computer.

    Seems when I opened the box and connected the iphone to the computer I did it too fast not letting the device start, i also got the following message:

    "You have inserted a disk containing no volumes that Mac OS X can read. To use the unreadable volumes, click Initialize. To continue with the disk inserted, click Continue."

    I hope this helps someone!
     
  6. HaroldC macrumors regular

    Joined:
    Jun 1, 2006
    #6
    I did the same thing and also restarted my computer as well. It finally worked after that. Good Luck.
     
  7. macmania8227 macrumors newbie

    Joined:
    Sep 30, 2007
    #7
    I tried switching off my iphone and computer but it still gives me the same error:(:(
     
  8. compuguy1088 macrumors 6502a

    compuguy1088

    Joined:
    Sep 3, 2007
    Location:
    In the Sub-Basement of Solitude
    #8
    Having exactly the same problem, tried rebooting my computer, no luck. I also tried rebooting the iPhone, nothing still.
     
  9. compuguy1088 macrumors 6502a

    compuguy1088

    Joined:
    Sep 3, 2007
    Location:
    In the Sub-Basement of Solitude
    #9
    Has anyone gotten around this issue by chance?? Because the iTunes music store works. The activation went though this final part. All I need to do is sync it to finish the process. But this comes up :(
     

Share This Page