"Could not create a preboot volume for APFS install" on MBP 2018

Discussion in 'macOS Mojave (10.14)' started by Yoms, Oct 9, 2018.

  1. Yoms, Oct 9, 2018
    Last edited: Oct 9, 2018

    Yoms macrumors member

    Joined:
    Jun 1, 2016
    #1
    Hi,

    I'm totally unable to use my MBP 2018 with T2 chip. I received it today from a retail non-Apple store. It came with High Sierra.

    1) I couldn't update to Mojave form MAS. After an hour or so I had downloaded only a few MB. I checked my Internet connexion on Speedtest.net and it resulted in a "socket error" at the end of the test. But, on my older MBP everything is running fine and normally (SpeedTest included). I tried again 3-4x times to update via MAS, rebooting the MBP 2018 eacht time, but same result.

    2) A bit concerned, I decided to go for a clean install of Mojave using Option + Cmd + R. I first erased the disk via DiskUtility and then started the Internet installation, but at end of installation I got the message mentioned in the thread title. All solutions seem to point to reverting back to HFS, but that's no longer an option with the newer MBP.

    3) I decided to go for USB install. I downloaded Mojave from MAS on the older MBP + createinstallmedia, but installation was a no go: the T2 secure enclave is configured to refuse install from external source and stated that I had to reboot in Option + Cmd + R to modify the security parameters (OK, fair enough).

    4) I did that, except that when I was invited to provide my macOS pwd, it stated that there was no admin accountconfigured. I mean WTF?! I thought the T2 chip would have stored my very first macOS pwd.

    Since the disk has been formatted, I'm left with no other option.

    What's wrong? What did I do wrong?

    Help would be appreciated as I literally can no longer use this brand new MBP.

    Thanks! (A LOT!!!)
     
  2. Uncle Freddie macrumors newbie

    Joined:
    Jul 13, 2015
    #2
    Interesting problem. Did you actually boot off the USB Mojave installer? For that, you would need to hold down Option during boot and choose the USB drive.
     
  3. Yoms thread starter macrumors member

    Joined:
    Jun 1, 2016
    #3
    Yes I did at step 3. Well, tried. But then I have a message about not being authorized for security reason.
    --- Post Merged, Oct 9, 2018 ---
    There's also another problem. When I try to do the Internet restoration, it doesn't work when the MBP is connected yo my xDSL home network. After having accepted the terms and selected the destination drive, I don't DL one single percent.

    But, if I do the same while connecting the MBP to my iPhone and share the connexion through my mobile carrier, I can DL. But at the end, I have the aforementioned issue about APFS.
     
  4. Yoms thread starter macrumors member

    Joined:
    Jun 1, 2016
    #4
    OK, for some unknown reason I repeated the Internet restoration and it worked. I really don't why why the AFPS didn't show up again, but I won't complain.

    I don't like this weird behavior. It reminds a Windows PC. That's exactly why I switched to Apple years ago. Also, I haven't tried to boot from USB install drive again just to see if my password works in T2 enclave or if it still states that there's no account defined.


    That said, I don't understand this T2 thing. It refuses to re-install from an external disk for security reason in case my computer is stolen. OK, fine. But it accepts to restore from Internet without asking any pwd. I mean, why this is more secure?
     

Share This Page

3 October 9, 2018