Couldn't eject external now disk not mounting

Discussion in 'Mac Basics and Help' started by Tybaltcap, Aug 15, 2009.

  1. Tybaltcap macrumors newbie

    Joined:
    Jul 19, 2008
    #1
    Hey gurus!

    I know this has been disccused ad nausium many places, but in reading 100s of posts Ive just confused myself and was hoping someone could help me make sense of all I've heard.

    I have a ibook g4 and use a WD 500gb external hard drive to keep all my music/pictures etc.

    Last night when I was moving files around (I dont think it was actually in the process of transferring files when this occurred, but there is a slight chance it was) I accidently hit enter instead of shift which told my computer to open all of the 1000+ folders that I had selected (DOH!) after working for an hour it seemed to be all frozen so with concern I turned the computer off and restarted.

    Suprise suprise, my external will no longer mount. - Disk Utility recognizes it but says there was an error on exit.

    I have heard about 3 possible solutions.

    1 - just connect my external to another computer, mount and then eject it (difficult to find another mac where I am)

    2 - Disk Warrior - $99 bucks and repairs drive right?

    3 - Data Rescue 2 - $99 and helps recover data right?

    For my specific situation - which is the software that you would recommend. Does Data Rescue just give me a hole jumble of unsorted data and then I need to go out and buy a new external hard drive?

    Does disk warrior seriously jeopardize my ability to recover data if I try it?

    Is option 1 a possibility and if so why would that work?

    Thanks!
    Tim
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    It amuses me how you typed the questions in the reverse order to your original statements. You remind me of my mother.

    Anyhow, you basically have your options covered there.

    I'll have to defer judgement on that one. I haven't used the app personally.

    If you recover data from a corrupted hard drive, you will have to put it somewhere. If you have enough free space elsewhere, you can just copy the files off the drive, format it, then put them back on. There is nothing wrong with the physical drive.

    No. If it doesn't work, you're no worse off than when you started, aside from being out $100 for your trouble. Bear in mind that DiskWarrior does not support NTFS.

    That depends how the drive is formatted. If it's NTFS, the drive was likely still flagged as "in use" when it was disconnected. Macs will refuse to read from a drive flagged as such, but Windows will do so without complaint. Plugging it into a Windows computer then ejecting it properly will remove the flag and allow the Mac to read it again.

    I doubt that trick will work if the drive is not NTFS. Plugging it into another Mac won't solve anything.
     
  3. Tybaltcap thread starter macrumors newbie

    Joined:
    Jul 19, 2008
    #3
    Humm

    The drive is not NTFS unfortunatly - and after a full 24 hour scan with Data Rescue it told me that only 300 of 480 gb could be recovered- but there is no organization to the files recovered, they are all renamed and put in different folders.


    Does this indicate that Disk Warrior would be unable to solve the issue (because Data Recovery was not able to access 100% of the files) or are they unrelated?
     
  4. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #4
    They're unrelated.
     
  5. Tybaltcap thread starter macrumors newbie

    Joined:
    Jul 19, 2008
    #5
    The Result!

    So I never got to try out Disk Warrior because for some reason the cheap and easy fix WORKED!

    Just popped my usb into a PC, and it recognized it immediatly - saftly ejected it and put it in my mac - and there it was!

    I have no idea why it worked - its a FAT32 drive (or something like that) but it did and I'm happy as pie - I suggest everyone with this problem try this solution first as a just in case.

    Thanks for all your help Blue Revolution - I really appreciate your time in helping me solve a very worrying problem
    Tim
     

Share This Page