"Couldn't start Dropbox." error

Discussion in 'OS X Mavericks (10.9)' started by FlatBot, May 22, 2014.

  1. FlatBot macrumors newbie

    Joined:
    May 22, 2014
    #1
    I have a MacBook Pro running Mavericks. I installed DropBox and it worked for a couple of days. Now for the last week or so, (since the last Mavericks update I think), whenever I launch Dropbox I get the message "Couldn't start Dropbox."

    Here's a picture: http://imgur.com/k7PVSbe

    Here's the text that is in the link in the error message: http://imgur.com/xu1QhbH

    I contacted DropBox support but they did not solve my problem.

    Here's what they said:

    It looks like you may have some files with permissions settings that block Dropbox. This often happens with users who may have migrated old data and settings from another Mac to their current computer.

    Operating system permissions prevent files from being viewed or edited by unauthorized logins. Permissions can be set any number of ways and can be restored manually through a fairly simple process. Please note that it is very important to follow these steps specifically as failure to do so may result in other issues:

    1) Make sure the Dropbox desktop application is running

    2) Click on the Dropbox icon in your menu bar and then click on the gear in the Notifications panel

    3) Select 'Preferences'

    4) Click on the 'Account' tab

    5) Hold down the 'Option' key

    6) Click on the 'Fix Permissions' button (make sure you're still holding down the 'Option' key.

    This will allow Dropbox access to your home folder, Dropbox folder, and any required settings.


    **
    However, on Step 3 - I cannot select "Preferences", as it is grayed out.

    I informed them of this days ago but they did not get back to me.

    Any ideas?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Where's your dropbox folder located. The screen shots are referencing /var/folders/xxx

    My dropbox folder is ~/Dropbox. No where near the system directories.
     
  3. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #3
    That's because it is a log file. Not the Dropbox folder.

    But the log file would probably provide quite a good clue as to why it wont start.
     
  4. FlatBot thread starter macrumors newbie

    Joined:
    May 22, 2014
    #4
    Sorry, I should have mentioned. I replaced my user name with xxx in the log file for the screenshot.

    Also, my Dropbox Directory (directory with my synced files) is also at ~/Dropbox

    ----------

    Here is the log file. The only thing I censored is my last name. (replaced with xxx)

    ***

    bn.BUILD_KEY: Dropbox
    bn.VERSION: 2.8.0
    bn.DROPBOXEXT_VERSION: failed
    bn.is_frozen: True
    pid: 8524
    ppid: 156
    uid: 501
    user_info: pwd.struct_passwd(pw_name='allan', pw_passwd='********', pw_uid=501, pw_gid=20, pw_gecos='Allan xxx', pw_dir='/Users/allan', pw_shell='/bin/bash')
    effective_user_info: pwd.struct_passwd(pw_name='allan', pw_passwd='********', pw_uid=501, pw_gid=20, pw_gecos='Allan Flatoff', pw_dir='/Users/allan', pw_shell='/bin/bash')
    euid: 501
    gid: 20
    egid: 20
    group_info: grp.struct_group(gr_name='staff', gr_passwd='*', gr_gid=20, gr_mem=['root'])
    effective_group_info: grp.struct_group(gr_name='staff', gr_passwd='*', gr_gid=20, gr_mem=['root'])
    DYLD_LIBRARY_PATH: None
    cwd: u'/Applications/Dropbox.app/Contents/Resources'
    real_path=u'/Applications/Dropbox.app/Contents/Resources'
    mode=040755 uid=501 gid=20
    parent mode=040755 uid=501 gid=20
    HOME: u'/Users/allan'
    appdata: u'/Users/allan/.dropbox'
    real_path=u'/Users/allan/.dropbox'
    mode=040700 uid=501 gid=20
    parent mode=040755 uid=501 gid=20
    dropbox_path: u'/Users/allan/Dropbox'
    real_path=u'/Users/allan/Dropbox'
    mode=040700 uid=501 gid=20
    parent mode=040755 uid=501 gid=20
    sys_executable: '/Applications/Dropbox.app/Contents/MacOS/python'
    real_path='/Applications/Dropbox.app/Contents/MacOS/python'
    mode=0100755 uid=501 gid=20
    parent mode=040755 uid=501 gid=20
    trace.__file__: '/Applications/Dropbox.app/Contents/Resources/lib/python2.7/site-packages.zip/dropbox/boot_error.pyc'
    real_path='/Applications/Dropbox.app/Contents/Resources/lib/python2.7/site-packages.zip/dropbox/boot_error.pyc'
    not found
    parent not found
    tempdir: u'/var/folders/7r/xk7nv9w52h55mc3sdnv_9ktr0000gn/T'
    real_path=u'/private/var/folders/7r/xk7nv9w52h55mc3sdnv_9ktr0000gn/T'
    mode=040700 uid=501 gid=20
    parent mode=040755 uid=501 gid=20
    Traceback (most recent call last):
    File "dropbox/client/authenticate.pyc", line 1155, in authentication_thread
    File "dropbox/client/authenticate.pyc", line 439, in finish_dropbox_boot
    File "dropbox/client/main.pyc", line 1534, in start
    File "dropbox/sync_engine/sync_engine.pyc", line 3364, in start
    File "dropbox/sync_engine/sync_engine.pyc", line 3342, in _start
    File "dropbox/file_cache/file_cache.pyc", line 2543, in refilter_queues
    File "dropbox/file_cache/memory_cache_backend_wrapper.pyc", line 138, in wrapped
    File "dropbox/file_cache/memory_cache_backend_wrapper.pyc", line 497, in refilter_queues
    File "dropbox/file_cache/util.pyc", line 149, in why_isnt_valid_filejournal_entry
    File "dropbox/attrs.pyc", line 394, in unmarshal
    CorruptedAttributeError: Invalid control character at: line 1 column 927 (char 926)
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Let's try to reset your home folder permissions back to default. Do a command-r boot to the recovery screen. Once there go to the Utilities menu and start Terminal. Then enter "resetpassword" (all one word without the quotes). You will get this screen.

    [​IMG]

    Select Macintosh HD at the top then select your user account in the drop down. Leave all three password fields blank as we don't want to change that. Now click the reset button at the lower right.

    Once that is done you can quit Terminal. Now since we are here anyway, go ahead and start Disk Utility and to both a repair disk and a permissions repair. I doubt either of these last two is your issue, but no harm in doing this while we are in recovery just for drill.

    Now reboot then reinstall the latest version of Dropbox (2.8.2) from here.

    See if that fixes the problem.
     
  6. FlatBot thread starter macrumors newbie

    Joined:
    May 22, 2014
    #6
    Sadly, it didn't work

    Thanks for the post. I tried your suggestion of resetting home directory permissions and running the disk utility repairs. Sadly, it didn't work.

    I still get the same error when starting Dropbox.

    One thing I should have done was completely uninstalled my previous DropBox installation before doing these procedures. I guess I can try that.

    Any other ideas?
     
  7. FlatBot thread starter macrumors newbie

    Joined:
    May 22, 2014
    #7
    fixed!

    OK I have DropBox up and running again.

    This time I uninstalled dropbox and deleted my local DropBox directory prior to following the procedure.

    The DropBox installer noticed my directory was deleted and relinked my account. I re-downloaded my synced files and DropBox is running once again.

    Hopefully it stays this way!

    Now it's time to look into Time Machine backups in case anything like this happens again!
     
  8. jrbcd macrumors newbie

    Joined:
    Jul 26, 2014
    #8
    To Flatbot

    Flatbots fix works for Dropbox. Thanks!!!:)
     
  9. defionscode macrumors newbie

    Joined:
    Sep 26, 2014
    #9
    Easier way

    Alternatively,

    you can go into the terminal and do:

    sudo chmod -R 744 ~/Dropbox/
     
  10. swis macrumors newbie

    Joined:
    Nov 24, 2014
    #10
    Dropbox Problem

    I hesitated a bit to go to such lengths, so just tried uninstalling Dropbox and re-installing it.

    To do so, I did all the actions listed here:

    https://www.dropbox.com/en/help/41

    including the contextual menu and application setting removal. I did KEEP the Dropbox folder however.

    Luckily it seems the synching is picking up nicely from my previous files rather than having to download everything again...

    Hope it works for some others too ; )
     
  11. jos0522 macrumors newbie

    Joined:
    Jul 14, 2015
    #11
    Hello! I know it's been more than a year since this thread was started, but, I found this while experiencing the same issue as FlatBot. Originally, what they said was correct for me too, the preferences option was grayed out -- but I realized this was because the pop up window with the error had already popped up, and once you click "ok," the Dropbox application closes down altogether. So, I then decided to try and beat Dropbox to the punch. I went to my applications and opened up Dropbox again -- but this time, I immediately went to the Dropbox icon on the menu bar and opened up my preferences before it could generate the pop up window with the error. I was able to successfully go to my account and follow steps 1-6 from the Dropbox support, and voila, upon fixing the permissions my Dropbox loaded and synced.

    Thanks for this helpful thread all! Glad to be syncing again. :)
     

Share This Page