Coverflow Annoyingly slow and jerky on Nvidia graphics Using vista

Discussion in 'Windows, Linux & Others on the Mac' started by crazy frog, Aug 9, 2007.

  1. crazy frog macrumors newbie

    Joined:
    Aug 9, 2007
    #1
    ok every one knows Nvidia graphics are the best even if most macs dont use them
    using Windows Vista itunes works really slow and jerky
    My original Specs of my PC where
    • Intel pentium d 820 at 2.8ghz
    • 1Gb DDR2 ram PC6400
    • XFX 7300LE
    1gb ddr2 ram pc6400

    I then upgraded to
    • E6600 core 2 duo at 2,4ghz
    • Nvidia INNO3D 7900gs

    Neither Of these improved the speed of coverflow
    However the problem doesnt happen at all on intel graphics
    also the problem doesnt happen in xp
    Only in Vista

    Has Any one else encountered this bug

    Ps if your gonna make some stupid mac comment dont bother replying to this
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
  3. crazy frog thread starter macrumors newbie

    Joined:
    Aug 9, 2007
    #3
    1. poor development of itunes
    2. crap company making itunes
    3. cant program for good easy to program software ie vista
     
  4. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #4
    I've never run iTunes on Vista so I wouldn't know it's performance on it. I agree that iTunes is poorly coded though.

    Are you running Intel graphics on Vista as well?
     
  5. LeviG macrumors 65816

    Joined:
    Nov 6, 2006
    Location:
    Norfolk, UK
    #5
    crazy frog - if you had done some research first you would have found that its common knowledge that the nvidia drivers on vista are absolute rubbish. It has nothing to do with itunes or apple coding as the intel drivers prove, its to do with nvidia not getting off of their behinds to get a decent set of drivers out. ATI and intel are far superior in this respect.

    Oh and Vista with 1GB of ram is going to be an issue on its own anyway, Vista really need 2GB+ of ram to work cleanly.
     
  6. crazy frog thread starter macrumors newbie

    Joined:
    Aug 9, 2007
    #6
    Ati are poor because theyre owned by AMD and they cant program software for there hardware properly which means they get bad performance out of their gpu's
    i heard a while ago that when they first brought out their DX10 gpu's the software they released gave poor performance
    and ati actually stated that the next software release would give a 20% improvement in performance
    Ive seen the difference first hand in games with Intel and Nvidia in games, media
    playback and pure technology
    And i can safely say that Nvidia are far superior to ati and intel

    Vista is perfect performance wise and i havent had any performance issues
    Ive read up on vista needing 2gb plus ram and its only for slower ram like ddr not ddr2 that you would need 2gb

    Ive actually emailed Nvidia about the problem and they actually said the problem is Apple not developing their software properly
    ie not testing on nvidia graphics

    Even if apple are quick in releasing bug fixes they havent been in this case in baring in mind how long their have been beta's and rc's of vista
    also i have over 200 programs installed on my pc and none of them suffer problems like apple software
     
  7. LeviG macrumors 65816

    Joined:
    Nov 6, 2006
    Location:
    Norfolk, UK
    #7
    ok I'll leave you in your own little world then. :rolleyes:
     
  8. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #8
    I have never had to revert back to a previous driver version with any of my ATI cards. But when I decided to try an Nvidia card I had to wait to hear what people said about the driver and stability before I could install it.

    ATI drivers are, for the most part, rock solid. Just look at the problem Nvidia have had getting decent drivers done for the 8800GTX. That is something they have been working at for 6 months+ and they are still having problems.
     
  9. crazy frog thread starter macrumors newbie

    Joined:
    Aug 9, 2007
    #9
    20% improvement just down to drivers is alot especially when its an expensive card from ati

    any way the whole point of starting this thread was to ask if ANYONE HAD ENCOUNTERED THIS PROBLEM

    ON VISTA

    WITH NVIDIA GRAPHICS
     
  10. LeviG macrumors 65816

    Joined:
    Nov 6, 2006
    Location:
    Norfolk, UK
    #10
    as it appears coverflow utilises direct x then the likely hood is yes.
     
  11. crazy frog thread starter macrumors newbie

    Joined:
    Aug 9, 2007
    #11
    plz im asking if any one has actually experienced the problem first hand
    if u havent or you cant give me a reference to someone who has Dont bother pointing out the obvious
     
  12. insitemotion macrumors newbie

    Joined:
    Aug 16, 2007
    #12
    I have experienced this as well

    I have experienced the slow performance of cover flow with Vista and a Nvidia 8600 GT. It's very annoying. I have tested my computer with an ATI x1300 Pro (everything else the same specs) and performance is perfect. The ATI card is much slower so speed shouldn't be issue. I'm doing more research into this and will post my findings if I find a fix.
     
  13. l'homme macrumors member

    Joined:
    Jun 30, 2006
    #13
    i'm using a windoze vista box, with ATI xt graphics, no problems at all with coverflow
     

Share This Page