Coverflow Question

Discussion in 'iPod touch' started by stockcerts, Jan 19, 2008.

  1. stockcerts macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #1
    I just bought my Touch this past week. So far I love it, but it seems like their may be a problem with Coverflow showing the correct artwork for the song that is currently playing.

    When I hold the Touch in portrait mode the correct artwork shows, but in landscape it often doesn't. Has anyone else seen this, user error maybe? :p

    I also added the new apps.
     
  2. Pared macrumors 65816

    Joined:
    Oct 19, 2007
    #2
    Sometimes the artwork database becomes corrupted after you a sync a large number of times.

    Not sure if this was fixed in 1.1.3.

    The only solution is to completely reinstall all your media from scratch. Terrible... I know.

    Hopefully 1.1.3 has corrected this.
     
  3. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #3
    If it is corrupt I'll just live with it until a fix comes along, or a new version. Thanks!
     
  4. Pared macrumors 65816

    Joined:
    Oct 19, 2007
    #4
    Ok. Just know that it will only continue to get worse with each sync.

    Also, if you manually try and fix it (remove songs that are "messed up") it will get even worse... so pretty much, no matter what you do, it will get worse.

    Just a heads up.
     
  5. rusty. macrumors member

    rusty.

    Joined:
    Sep 22, 2007
    Location:
    Houston, Texas
    #5
    Ehh thats happened to me or it has the right art just the wrong artists in coverflow not anywhere else,
     
  6. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #6
    Try verifying the artwork in iTunes. Select and entire album, get info (cmd-i), copy the artwork and then paste it in again, and save. This will assure that all the tracks on the album have the same artwork. You should also make sure that the artist and album names are precisely the same for each track (can be done the same way as the artwork). Small differences which do not show up in iTunes often create coverflow issues on the touch.
     
  7. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #7
    Think it's worth contacting Apple to see if their is a fix?
     
  8. Domofloge macrumors regular

    Domofloge

    Joined:
    Jan 5, 2008
    Location:
    New Jersey
    #8
    I experienced the same problem as you! I eventually figured there was nothing I could do about it, but randomly after a sync with my Macbook, it was correct!

    Divine intervention i guess... :D
     
  9. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #9
    I think it's worth trying my suggestion first.
     
  10. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #10
    I may not be understanding your suggestion. I don't have many complete albums, mostly a big mix of songs. If I go through each song (mostly bought from Itunes), that could take many..many hours. Plus, I am guessing coverflow on Itunes is fine, it's only on my Ipod that it isn't right.
     
  11. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #11
    I thought I'd post this follow-up question. I'm surprised my ITunes database could get messed up this fast...I only bought my Touch this past Tuesday.

    Maybe I should restore the unit...which I believe will be like reformating. If I do this I hope I don't lose my new apps I just paid for. Thoughts?
     
  12. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #12
    Maybe I'm not really understanding your problem. When you say the artwork is "incorrect," are you saying it displays artwork for a different album? Does it show generic artwork?

    In the past I've found that most problems of this kind can be fixed in iTunes by making sure that every track from a given album has the same artwork, and also making sure that the artist and album name are exactly the same. Variations which iTunes does not display are not tolerated on the touch.
     
  13. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #13
    I typically listen to playlists. For instance, I have one called "gym", and as you can guess I listen to this one at the gym. The song playing doesn't match up with the song showing, but sometimes it does and it has the wrong art work, or the generic artwork. When a new song from my playlist begins playing the artwork doesn't advance to the next song. When I hold my Ipod in the portrait position it usually will adjust to the correct song and artwork.

    On Itunes the artwork from my gym playlist is correct, so I don't believe the problem is stemming from Ituness.
     
  14. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #14
    It shows the wrong song title? That's different than artwork. Or is that not what you are saying?

    Either way, try what I suggested. Differences which do not show up in iTunes are not tolerated on the touch, especially in coverflow. Problems with artwork don't stem from iTunes, but they can be corrected in iTunes.
     
  15. Nickelz92 macrumors member

    Joined:
    Jan 21, 2008
    #15
    I sort of had the same problem. When I listen to the song in portrait, it displays perfectly. However, when I move it into Cover Flow it just displays the first alphabetical album. Is that not how its supposed to work? :confused:
     
  16. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #16

    That does sound like the same problem I'm having! :confused:
     
  17. apsterling macrumors 6502a

    apsterling

    Joined:
    Nov 24, 2007
    #17
    Here's how I fixed this problem back when art was wonky on my 5th Gen (I believe it's the same root problem) No restore is necessary.

    Open .../iTunes/Album Artwork/ and delete the files in there. Open iTunes, and regrab all the artwork you lost from Apple's servers. Resync, and hopefully it'll work.

    What happened is that your artwork database got corrupted- deleting the files removed art you downloaded using iTunes. Any mp3s with art in them won't be affected. Then take the time and retrieve the artwork and resync, and it should solve the problem.
     
  18. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #18
    Can you give me the complete path to that folder? Thanks!
     
  19. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #19
    I found the folders and deleted them as suggested. It didn't help. Even some of my newly purchased album artwork is no longer showing up. When I'm playing music on playlists coverflow continues to show music (in portrait position) that is not currently playing.

    Very aggrevating.
     
  20. stockcerts thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    Location:
    San Francisco, CA
    #20
    Most of my problem has been resolved. Someone on the Apple support forums provided the answer. When you connect your ipod to your Mac, click on the music tab. Next turn off music syncing. This will remove all songs from your Ipod. Go back and turn on music syncing and sync up again.

    All of my artwork appears to be OK now.
     
  21. Pared macrumors 65816

    Joined:
    Oct 19, 2007
    #21
    I told you to do that two days prior and you're crediting someone from the Apple forums? :rolleyes:
     

Share This Page