cpu running at 94% with nothing open please help

Discussion in 'Mac Basics and Help' started by sherwoodfilms, Jan 5, 2010.

  1. sherwoodfilms macrumors newbie

    Joined:
    Jan 5, 2010
    #1
    i have rpc.statd PID 264 and PID 267 running at 92% and 94%
    my mac is 17inch 2.66 intel core 2 duo
    4 gig of ddr3 ram
    running snow leopard 10.6.2

    its killing my battery life and i cant stop it can anyone help.

    even with all aps closed it still is running at that speed.

    here is a sample

    Analysis of sampling rpc.statd (pid 267) every 1 millisecond
    Call graph:
    2410 Thread_2432 DispatchQueue_1: com.apple.main-thread (serial)
    2410 0x1d2e45284
    2410 0x1d2e48807
    2410 0x1d2e4686e
    1289 0x1d2e45a98
    1288 open
    1 0x1d2e45a98
    499 0x1d2e45b7e
    499 fcntl
    495 __fcntl
    4 fcntl
    465 0x1d2e45cdb
    464 close
    1 0x1d2e45cdb
    148 0x1d2e45bc4
    148 read
    3 0x1d2e45b3d
    2 0x1d2e45a93
    1 0x1d2e45a85
    1 0x1d2e45a89
    1 0x1d2e45a9e
    1 0x1d2e45b80

    Total number in stack (recursive counted multiple, when >=5):

    Sort by top of stack, same collapsed (when >= 5):
    open 1288
    __fcntl 495
    close 464
    read 148
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
  3. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #3
    yep but just kicks in as soon as i start. i think its a program running something in the back ground but dont know which one and dont know how to stop it.

    its strange that on my other log in it doesnt come up.
     
  4. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #4
    open your activity monitor and post a screenshot.
     
  5. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #5
    rpc.statd

    Not sure what exactly it's doing on your machine... have you tried killing it?
     
  6. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #6
    tried killing and just kicks in again

    how do i upload my screen shot? sorry i know its a dumb question
     
  7. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #7
    Command Shift 4 Space

    click on the activity monitor window (make sure the drop-down is set to "All Processes" and its sorted by CPU)

    Then there's a "Manage Attachments" button below the reply box in the forums.
     
  8. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #8
    attached is a screen shot
     

    Attached Files:

  9. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #9
    basically after i upgraded to sl it started to happen my battery life went from 4-5 hours down to 1.5- 2 so i started looking my fans are running crazy time and my temp is consistently up on the cpu 88 degrees even when nothing going on
     
  10. Mumford macrumors regular

    Joined:
    Oct 8, 2006
    Location:
    Altadena, CA
  11. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #11
    Are you running any type of server ? That's what it looks like.
     
  12. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #12
    no not running a server have a mobile me account but didnt think that would affect it.

    how do i get access to my system. log?
     
  13. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #13
    Utilities> Console.

    The logs will be on the left.

    rpc is a remote procedure call that is used in file sharing and servers.
     
  14. Mumford macrumors regular

    Joined:
    Oct 8, 2006
    Location:
    Altadena, CA
    #14
    Use Console.app (/Applications -> Utilities -> Console). See the attached screen shot. You don't need to cut-and-paste a picture for us, just use the Filter (top right) to search for rpc.statd and see if there are a lot of lines that repeat themselves.
     

    Attached Files:

  15. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #15
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] CopyFolder -- actualObjects retrieved from FSGetCatalogInfoBulk: 4
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] ProcessFolderList -- Copying contents of
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] /Volumes/AcroProUpd910_all/Acrobat 9 Pro Patch.app/Contents/Resources/no.lproj/MainMenu.nib
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] to
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] /Users/matt/Library/Caches/Adobe/Updater6/acrobat9pro-EFG/Acrobat 9 Pro Patch.app/Contents/Resources/no.lproj/MainMenu.nib
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] CopyFolder -- actualObjects retrieved from FSGetCatalogInfoBulk: 3
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] ProcessFolderList -- Copying contents of
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] /Volumes/AcroProUpd910_all/Acrobat 9 Pro Patch.app/Contents/Resources/pl.lproj
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] to
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] /Users/matt/Library/Caches/Adobe/Updater6/acrobat9pro-EFG/Acrobat 9 Pro Patch.app/Contents/Resources/pl.lproj
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] CopyFolder -- actualObjects retrieved from FSGetCatalogInfoBulk: 4
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] ProcessFolderList -- Copying contents of
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] /Volumes/AcroProUpd910_all/Acrobat 9 Pro Patch.app/Contents/Resources/pl.lproj/MainMenu.nib
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] to
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] /Users/matt/Library/Caches/Adobe/Updater6/acrobat9pro-EFG/Acrobat 9 Pro Patch.app/Contents/Resources/pl.lproj/MainMenu.nib
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] CopyFolder -- actualObjects retrieved from FSGetCatalogInfoBulk: 3
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] ProcessFolderList -- Copying contents of
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] /Volumes/AcroProUpd910_all/Acrobat 9 Pro Patch.app/Contents/Resources/pt.lproj
    03/01/2010 19:40:05 [0x0-0x1b01b]."com.Adobe.ESD.AdobeUpdaterApplication"[218] to
    03/01/2010 19:41:07 com.apple.launchd.peruser.501[166] (com.logmein.logmeinguiagent[200]) Exited with exit code: 1
    03/01/2010 19:45:18 com.apple.launchd[1] *** launchd[1] has started up. ***
    03/01/2010 19:45:41 com.apple.SystemStarter[31] Starting Broadband Optimizer
    03/01/2010 19:45:41 com.apple.SystemStarter[31] Starting Qmaster services
    03/01/2010 19:45:41 com.apple.SystemStarter[31] Starting ProTecVb Server
    03/01/2010 19:45:41 com.apple.SystemStarter[31] -S
    03/01/2010 19:45:47 com.intego.commonservices.daemon[60] Upgrading preferences to format 3
    03/01/2010 19:46:02 com.apple.launchd[1] (com.logmein.logmeinguiagent) Unknown key for boolean: UseLMILaunchAgentFixer
    03/01/2010 19:46:04 com.logmein.logmeinguiagent[137] WINLOG - 6 Main LMIGUIAgent waiting for window server connection
    03/01/2010 19:46:04 com.logmein.logmeinguiagent[137] WINLOG - 6 Main LMIGUIAgent started:137 uid:0 (parent:1 launchd)
    03/01/2010 19:46:04 com.apple.launchd[1] (0x10011fb90.mach_init.VersionCueCS2Daemon[141]) Exited with exit code: 1
    03/01/2010 19:46:07 com.logmein.logmeinguiagent[137] WINLOG - 7 SessionManager SessionAgentStarted
    03/01/2010 19:46:09 com.apple.WindowServer[106] Sun Jan 3 19:46:09 matt-browns-macbook-pro-43.local WindowServer[106] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
    03/01/2010 19:46:22 com.apple.launchctl.Aqua[154] launchctl: Please convert the following to launchd: /etc/mach_init_per_user.d/trial_expired_NTFS.plist
    03/01/2010 19:46:22 com.apple.launchd.peruser.501[151] (com.logmein.logmeingui) Unknown key for boolean: UseLMILaunchAgentFixer
    03/01/2010 19:46:22 com.apple.launchd.peruser.501[151] (com.logmein.logmeinguiagent) Unknown key for boolean: UseLMILaunchAgentFixerDebugger() was called!
    03/01/2010 20:02:43 com.apple.launchd[1] (com.apple.lockd[241]) Exited with exit code: 1
    03/01/2010 20:05:55 com.apple.launchd[1] (com.apple.lockd[248]) Exited with exit code: 1
    03/01/2010 20:09:07 com.apple.launchd[1] (com.apple.lockd[257]) Exited with exit code: 1
    03/01/2010 20:12:19 com.apple.launchd[1] (com.apple.lockd[265]) Exited with exit code: 1
    03/01/2010 20:15:31 com.apple.launchd[1] (com.apple.lockd[271]) Exited with exit code: 1
    03/01/2010 20:18:43 com.apple.launchd[1] (com.apple.lockd[276]) Exited with exit code: 1
    03/01/2010 20:21:55 com.apple.launchd[1] (com.apple.lockd[281]) Exited with exit code: 1
    03/01/2010 20:25:07 com.apple.launchd[1] (com.apple.lockd[286]) Exited with exit code: 1
     
  16. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
  17. Mumford macrumors regular

    Joined:
    Oct 8, 2006
    Location:
    Altadena, CA
    #17
    So did you search for rpc.statd and found nothing?

    I think this line is interesting:
    03/01/2010 19:46:22 com.apple.launchctl.Aqua[154] launchctl: Please convert the following to launchd: /etc/mach_init_per_user.d/trial_expired_NTFS.plist​
    Have you installed some utility that supports read/write NTFS? I believe (but I'm not sure) those use some form of loopback NFS whick could trigger rpc.statd. You might try uninstalling that.
     
  18. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #18
    just deleted my nstf program well uninstalled all of it and restarted still no difference. did a search and it said it was something to do with servers but i dont have a server or anything server like connected with this machine.

    urgh its very frustrating!
     
  19. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #19
    one thing that is different it now says PID 33 67 dont know if that means anything?
     
  20. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #20
    "03/01/2010 19:45:41 com.apple.SystemStarter[31] Starting ProTecVb Server"

    You have a type of server running.

    [​IMG]
     
  21. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
  22. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #22
    sorry guys ive got to go and wont have internet til about this time tomorrow. Thanks for all your help and if anyone does come up with anything please post would be massively appreciated!!!
     
  23. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #23
    hi guys any idea what this might be on the console i keep getting this -
     

    Attached Files:

  24. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #24
    I'd try reinstalling Mac OS X on your machine. Make sure you have your data backed up first.
     
  25. sherwoodfilms thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #25
    ok cool will do.

    Strange thing is that even in safe mode still comes up!
     

Share This Page