CPU usage... corespeechd

Discussion in 'Mac mini' started by tpivette89, Dec 4, 2018.

  1. tpivette89 macrumors 6502

    tpivette89

    Joined:
    Jan 1, 2018
    Location:
    Newark, DE
    #1
    After intensely looking at Activity Monitor, I noticed that a certain task was excessively diminishing CPU usage... this process was named "corespeechd". It would spike my CPU usage at around 30 - 50 %, and cause the fans to ramp up.

    Anyone know what process caused this drain on system resources? And how to disable it? Nothing seems to enhance nor impact performance of this particular process...
     
  2. rmdeluca macrumors 6502

    Joined:
    Oct 30, 2018
  3. macdos macrumors regular

    macdos

    Joined:
    Oct 15, 2017
    #3
    Happened to me as well on first boot. Enable and disable that stupid Siri thing, reboot and it's gone.

    It's just not utilizing a full core, it's also gobbling up as much RAM as it can.
     
  4. leo-tech, Dec 5, 2018
    Last edited: Dec 5, 2018

    leo-tech macrumors regular

    leo-tech

    Joined:
    Sep 23, 2017
    #4
    The question is, why corespeechd should come ENABLED by default in the first place, taking into consideration that there is no embedded microphone in Mac Mini 2018?

    UPDATE: the related question, is there some practical way to monitor and control various services/daemons? (other than reading their cryptic names in Activity Monitor and feeding them to search engine).
     
  5. F-Train macrumors 65816

    Joined:
    Apr 22, 2015
    Location:
    NYC & Newfoundland
    #5
    I have Siri enabled and Activity Monitor says that corespeechd is using 0% CPU.
     
  6. tpivette89 thread starter macrumors 6502

    tpivette89

    Joined:
    Jan 1, 2018
    Location:
    Newark, DE
    #6
    Siri is disabled currently, but I will try turning it off and on and then rebooting the machine. Hopefully it gets rid of this annoyance.
     
  7. rmdeluca macrumors 6502

    Joined:
    Oct 30, 2018
    #7
    If we're talking about basic speech services, if you plug in an ordinary set of Apple headphones (the ones that used to come with iPhones and iPads before they switched to the Lightning connector, the "EarPods with 3.5mm Headphone Plug"), or any compatible 3-ring headphone+microphone for that matter, it's ready to go. There are hotkeys that can enable dictation from a fresh install of macOS for accessibility reasons.

    What's not clear is corespeechd's role in all of this. "CoreSpeech" is a private framework meaning there's no public developer documentation on it and it's not meant to be used by non-Apple developers. It seems to be a relatively recent addition to macOS and iOS. If you look at a recent dump of the symbols exposed by CoreSpeech you can see there's potentially a ton of functionality that is nebulously involved with speech recording and recognition:

    http://developer.limneos.net/?ios=11.1.2&framework=CoreSpeech.framework

    Which is normal. From what I've observed other agents/processes actually perform the grunt work of listening, processing and responding to Siri requests.

    Yet some people are having problems with corespeechd and toggling Siri seems to help:

    https://discussions.apple.com/thread/8643914
     
  8. tpivette89 thread starter macrumors 6502

    tpivette89

    Joined:
    Jan 1, 2018
    Location:
    Newark, DE
    #8
    Enabled then disabled Siri and shut down my Mini. Rebooted, and all seems to be well. Good riddance, corespeechd!
     
  9. billscores macrumors newbie

    Joined:
    Jan 2, 2019
    #9
    Thought I'd post here. I've got a new Mac mini i7. Fan started running loudly, which was strange because this thing is normally dead quiet. Turned off all apps. Checked activity monitor, and corespeechd was running at over 100 percent cpu. Rebooted and it went away. Since ,corespeechd has been normally between .8 and 10 % cpu, although I had another episode today where it escalated into 100% plus. rebooted and it was gone. I don't use Siri. It's off. However, I do have a pro core audio system installed for Logic (UAD Apollo 8x TB3 interface) which is always plugged in and active.
     
  10. colinwil macrumors regular

    Joined:
    Nov 15, 2010
    Location:
    Reading, UK
    #10
    The fix - as detailed by others in this thread - is to turn Siri on, then off again, then reboot. It worked for me - I did that back in mid December and haven't had any problems with corespeechd since.
     
  11. lshaner macrumors regular

    lshaner

    Joined:
    Mar 7, 2007
    #11
    Interesting... The link says the site is down for maintenance, yet other threads load.
     
  12. Easttime macrumors 6502a

    Joined:
    Jun 17, 2015
    #12
    Just had this problem start up on my 2018 Mac mini (heating up, fan 4000 rpm, corespeechd CPU use at 114% according to iStatMenus). This fix seems to have worked after a reboot. Hopefully it holds.
     
  13. oofoofoof macrumors newbie

    Joined:
    Jun 7, 2019
    #13
    I tried this method and it didn't work, this thing is communicating with the network too which erks me.

    This thread is old but I found the corespeech.plist file this morning, apparently you just can't delete or edit files on a mac even if you're sudo, wow apple is great . . .

    /System/Library/LaunchAgents/com.apple.corespeechd.plist

    And yes I tried changing the permissions
     
  14. StellarVixen macrumors 68000

    StellarVixen

    Joined:
    Mar 1, 2018
    Location:
    Earth
    #14
    It’s Siri, that’s why it’s connecting to the Internet often.
     
  15. oofoofoof macrumors newbie

    Joined:
    Jun 7, 2019
    #15
    Yes I understand that, I would be ok with it if it didn't do that while it was disabled.

    anyway if anyone finds this thread the way I did and wants to disable the corespeechd service for privacy or performance
    you'll need to hard reboot your computer holding command + R on boot, open a terminal and run `csrutil disable` and reboot to allow the editing of System Integrity Protected files, sounds scary right? you can run `csrutil enable` the same way.

    then go edit that file in `/System/Library/LaunchAgents/com.apple.corespeechd.plist` and remove the part that autoruns it, or if you don't care about siri delete it.
     

Share This Page

14 December 4, 2018