CR2 files won't open anywhere on my Mac

Discussion in 'macOS' started by tuesdayschild, Jun 17, 2008.

  1. tuesdayschild macrumors newbie

    Jun 17, 2008
    can I ask for some help with this, please. I use a Canon 5D camera and a Sandisk Extreme IV 4Gb card.

    Last night I got back from the Elbow gig and pulled the RAW images off the card. They loaded up in Bridge but they don't have actual picture thumbnails. They are named correctly, ie: IMG_3483.CR2 but they won't open!? Error message says 'Could not complete your request because Photoshop does not recognise this type of file' even though I have been using RAW for months.

    I could see them on the back of the camera before I copied the images off the card.

    I did a general Mac software update the other day and I noticed that there was an update for ACR. Could it have been something to do with that? I tried another Mac but get exactly the same result so it's not my Mac although it might have been something that happened when I copied the images over?

    Since I copied the images into a file on my Desktop, the camera will no longer show the pictures, I just get a message saying 'Camera cannot display image'.

    Any clues?
  2. jdavtz macrumors 6502a

    Aug 22, 2005
    How big are the CR2 files you have on your Mac? Do they sound like they're a reasonable size?

    Try dragging one into iPhoto or Preview - they both can view CR2 files (admittedly from a 40D but if they can do that I expect they can open them from a 5D too).
  3. mholsonproject macrumors newbie


    Jul 17, 2008
    CR2 won't open ?

    Are they transferring properly from your camera? The previous post makes a great comment ... what are the file sizes of those RAW files? Are they the same size as the JPG?

    I had a similar problem with my Canon EOS 450D.

    I write a little blurb on my site about my observations ... if you are interested?

    Not sure if it will help, but thought I would throw it out your way.

Share This Page