Cranky Mac only with 9600m

Discussion in 'MacBook Pro' started by adamvk, Jun 5, 2009.

  1. adamvk macrumors 65816

    adamvk

    Joined:
    Oct 29, 2008
    Location:
    Phoenix, AZ
    #1
    So I've started to discover that my Macbook Pro is a good amount slower when I'm using the 9600m, and sometimes the gaming performance is WORSE. Any one have any clue why?
     
  2. Skika macrumors 68030

    Joined:
    Mar 11, 2009
  3. adamvk thread starter macrumors 65816

    adamvk

    Joined:
    Oct 29, 2008
    Location:
    Phoenix, AZ
    #3
    Indeed. :(
     
  4. Biolizard macrumors 6502

    Joined:
    May 20, 2008
    Location:
    London, United Kingdom
    #4
    Considered taking it into the Store? Because that doesn't sound right at all.
     
  5. w00t951 macrumors 68000

    w00t951

    Joined:
    Jan 6, 2009
    Location:
    Pittsburgh, PA
    #5
    It depends. The NVIDIA 9400GT has a much more developed driver package, because it is used for the Macbook Air, Pro, and classic. However, I am sure that Apple will make an update for the package, soon. It's called PRO for a reason, you want that power.
     
  6. Warranty Voider macrumors 6502

    Joined:
    Aug 27, 2008
    Location:
    Maine, US
    #6
    It's a driver issue. There have been a ton of threads about this. People always say that apple will release a new driver update soon, but they haven't for a while now. None of the updates so far have done anything. I doubt Snow Leopard will fix it. IMO, it will take apple another 6 months to a year to fix it.
     
  7. carlosbutler macrumors 6502a

    carlosbutler

    Joined:
    Feb 24, 2008
    Location:
    London City
    #7
    ive not really found that. if im booted into os x and play world of warcraft, it runs on the highest possible settings. if i boot into XP and play something like left 4 dead, still on highest settings. both ways have decent frame rates (30+) well WoW actually has about 50+:D
     
  8. celtikmind macrumors 6502

    Joined:
    Feb 9, 2009
    #8
    I am so tired of hearing things like this, I would expect this from a PC/Windows. Why can't Apple fix their s**t?! They sure get paid for it! :mad:
     
  9. Biolizard macrumors 6502

    Joined:
    May 20, 2008
    Location:
    London, United Kingdom
    #9
    You can bet your bottom dollar/pound/other worthless currency that if the iPhone had a 9600, it'd be fixed tomorrow.
     
  10. celtikmind macrumors 6502

    Joined:
    Feb 9, 2009
    #10
    Yeah, that's the tragic part and imho, Apple's biggest threat to itself though it still seems to be clouded for most people.
     
  11. adamvk thread starter macrumors 65816

    adamvk

    Joined:
    Oct 29, 2008
    Location:
    Phoenix, AZ
    #11
    Well thanks for the comments. Hopefully it IS just a driver issue and will be fixed soon.

    Maybe Snow Leopard will fix it...
     
  12. atheros07 macrumors member

    Joined:
    Mar 21, 2009
    Location:
    Cambridge, MA
    #12
    Back to the OP, can you be more specific as to what problems you're having with the 9600 (which apps/games are slow)? It should not be purely a driver issue-- the 9600 shouldn't be performing worse than the 9400.

    In everyday tasks, I really don't notice any difference between the 9400 or 9600, but I definitely do see a gaming boost with the 9600. If you're not experiencing this, then something might be wrong with your 9600 card.
     
  13. adamvk thread starter macrumors 65816

    adamvk

    Joined:
    Oct 29, 2008
    Location:
    Phoenix, AZ
    #13
    Well every day things seem to start slower. With the 9600, iPhoto+iMovie+Safari takes longer sometimes, Archicad is a little slower, and things just seems to lock up more.
     
  14. celtikmind macrumors 6502

    Joined:
    Feb 9, 2009
    #14
    If you said that from the get-go... Definitely driver issue then. Don't waste anymore time trying to find a solution. You can only wait for Apple to fix it (any year now) like the rest of us.
    :(
     

Share This Page