Resolved Crap...iPhone 6 BSD

Discussion in 'Jailbreaks and iOS Hacks' started by IrishVixen, Nov 17, 2014.

  1. IrishVixen, Nov 17, 2014
    Last edited: Nov 18, 2014

    IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #1
    So...jailbroken on 8.1, just went to blue screen of death a few minutes ago. Screen IS lit, but blank (not DFU, as near as I can tell). Does not respond to any buttons. iTunes doesn't see it. Neither does PhoneView.

    Options?

    (Glad I still have a working, JB'd iPhone 5. But this sucks, to have it happen right as 8.1.1 drops.)

    Edit: OK, tried at least a dozen times before posting, but this time a hard reset seems to have kicked it back into first normal behavior, then safe mode. I have some ideas on what to remove that I'll start with. That said...is this likely simply a temporary hiccup, or a hardware issue? I've never had this kind of thing with previous phones, so I'm working a bit blind here.

    Edit 2: Well, after removing a few things, including the most recent tweak, mikoto, it's running fine again. It did get VERY hot while blank-screened, and some nosing around on Google indicates a possible kernel-panic. The same symptoms apparently happened before on even some stock iPhone 6's that required replacement, which is not reassuring. LOL

    Edit 3: Reinstalled mikoto. Ran fine last night. This morning, rebooted on a hunch and sure enough, a blue screen crash followed by a bootloop. Getting into safemode required a couple of tries. Removed mikoto, tried again. Another bootloop. Booted again into safemode, went to Cydia & did a reinstall of Cydia Substrate. That seems to have cleared the issue; no bootloops now either on resprings or reboots.

    Reddit has mikoto listed as part of a "how to protect your 8.1 jailbreak" thread. Others (in the comments) are reporting issues similar to mine, some have had to redo their jailbreak to get the bootloops to stop. I'd personally suggest avoiding that particular tweak for now.
     
  2. Zac7 macrumors 6502a

    Joined:
    Jan 9, 2011
    #2
    What caused it?
     
  3. IrishVixen thread starter macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #3
    Haven't gotten that far yet. I was actually just trying to tether the iPad to the phone via Bluetooth (tethering is carrier enabled, not via JB) which I've done half a dozen times, but I did have YouTube playing in the background at that time via a tweak called mikoto (recommended over on reddit).

    I've messed with a few other things today though, mostly theming. My own fault, I'm sure, assuming there's no actual underlying hardware issue.

    I haven't tried taking it out of safe mode yet now that it decided to wake back up. Removing mikoto and a couple of others first.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    My 6+ has done this a few times since jailbroken. Only fix is reboot
     
  5. IrishVixen thread starter macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #5
    Interesting, and good to know. It definitely ignored all attempts to do anything for a good ten minutes. What finally woke it was a hard reset (power + home) that I held for over a minute before it finally responded. I also removed the case due to the heat--no clue if that did anything. I'd tried a hard reset without holding it quite so long a number of times previously with no results, plus simply holding the power button for varying lengths of time.
     

Share This Page