Crappy Wi-Fi on new MBP

Discussion in 'MacBook Pro' started by jbischke, Jan 28, 2009.

  1. jbischke macrumors newbie

    Joined:
    Jan 27, 2009
    #1
    Just bought a new unibody MBP. Transferred all of my stuff over from an existing Time Machine backup (I was an older MBP before). Everything went smoothly. However, I'm noticing a lot of wi-fi problems (I had none before). Websites are either really slow or unreachable. Intermittent though as sometimes it works fine. A few things I've tried so far:

    -Restarting the router (Airport Extreme)
    -Updating the Airport Extreme firmware
    -Changing the channel the wireless was on (from 8 to 9)
    -Doing a Software Update
    -Adding a $ sign in front of my password

    When I'm hardwired web surfing is fine so it's a wi-fi issue.

    When I view the list of available networks I also show as connected to my network. However, it also shows as "Airport: Scanning..." with the wheelie thing going round and round. :)

    I'm in an apartment building with a lot of other networks around. However, that's never been a problem before.

    Any suggestions?
     
  2. Tracer macrumors 6502

    Joined:
    Jun 20, 2007
    #2
    Macbook Pro's have notoriously lousy wireless due to the aluminum casing

    Wikipedia: Faraday Cage

    If your computer is the only one on the Network or all your devices are 'N' you might want to try switching to 5 GHz only band.

    Tracer
     
  3. Atomicfission92 macrumors regular

    Joined:
    Jan 18, 2009
    #3
    You would really benefit from turning on the 5Ghz band. Its basically made to stop interference from other Wi-Fi networks, Cordless phones, Toaters, Etc.
     
  4. Sir Cecil macrumors 6502a

    Joined:
    Mar 31, 2008
    #4
    No suggestions I'm afraid, but my older MBP loses wi-fi connection whenever I burn a CD via Toast, with my outboard burner.
    Each and every time, after burning, I can't get back online. I have to restart and reset, sometimes two or three times before anything becomes active again.
     
  5. nopassn macrumors regular

    Joined:
    Jan 15, 2009
    Location:
    Kansas City
    #5
    I rock the Whitebook currently, and it was fine on G, but seemed slow on N. Then I got to tinkering with my router (Linksys 610N) and turned on dual band (2.4 and 5) and it straight up screams on N now. I would try the 5 Ghz band as well...
     
  6. dvdhsu macrumors 6502a

    dvdhsu

    Joined:
    Mar 28, 2008
    Location:
    Palo Alto, CA
    #6
    Yes. With N, it would be much faster.
    If that doesn't work, there isn't much else you could try.
    Is there a "power setting" on those?
     
  7. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #7
    I just use wireless G and my MB is fine. You might try AirRadar to avoid channels in use and change accordingly.

    You might also use the Airport Radar Widget to do the same type of thing.

    FYI, a change from channel 8 to 9 is unlikely to change anything. But yes you should definitely be removing any 2.4GHz phones from the house and keep in mind that any phones even at the 5.8GHz band often communicate some portions of their signal back to the receiver at 2.4GHz so they should be kept away from the router.
     
  8. nopassn macrumors regular

    Joined:
    Jan 15, 2009
    Location:
    Kansas City
    #8
    You've mistunderstood what I was trying to say - of course N is faster than G. What I was saying is, it was fine on G - because I was only running at 54mbps... when I wend to N, and was running in single mode it didn't speed up at all - it wasn't 'till I went in the router and kicked on both the 2.4 and 5 Ghz radios that I got the better speeds ~240 mbps. I don't think there is a power setting in my 610N...
     
  9. jbischke thread starter macrumors newbie

    Joined:
    Jan 27, 2009
    #9
    I switched my Airport Express router to N-only and that largely seemed to fix the problem at my apartment. However, everywhere else I'm going I'm having problems trying to connect to wi-fi. For example, this morning I was in a Starbucks (I have a T-Mobile plan) and my connex was dropping every couple of minutes.

    I had an old MBP and have been to a million Starbucks and I can't recall one time where I ever had a connection drop. Now on my new MBP the first time I go to one I can't get connected consistently. This is really frustrating as nowadays if you can't get a solid net connection your computer is pretty much worthless.

    Any suggested fixes?
     

Share This Page