Crashed iPhone 6 shows DFU itunes screen when connected to charger, but nothing when un

Discussion in 'iPhone Tips, Help and Troubleshooting' started by hypotc, Aug 13, 2017.

  1. hypotc, Aug 13, 2017
    Last edited: Aug 13, 2017

    hypotc macrumors member

    Joined:
    Mar 7, 2012
    #1
    My SO has an iPhone 6 that crashed about a year ago (I think it had the newest version of iOS9). Didn't do anything about it then, but got a new phone.

    I'm trying to get it working again now, but I'm running into a problem. Whenever the phone is connected to a charger, the Apple logo shows up, then the recovery DFU screen (The one with a cable and iTunes logo). However, when I unplug the phone the screen just turns instantly black, like it doesn't charge up the battery.

    The screen and home button have been changed, and I read somewhere that iOS9 had some sort of thing that locked you out of the phone if the Touch ID Home button didn't match the motherboard or something. I don't think the battery is dead, because when I plug it into iPhone with the cable it recognizes an iPhone in recovery mode after holding home+power. It just appears that it can't show anything on the screen when it's not plugged in to a wall socket.

    When I try to restore in iTunes it stops at "Waiting for iPhone".
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    ten-zero-eleven-zero-zero by zero-two
    #2
    Sounds like a hardware issue. I'd take it to Apple to diagnose.

    But I wonder if you can use software to kick it out of recovery mode. Something like Tiny Umbrella maybe.

    PS, the screen you describe (iTunes logo with cord) is just Recovery Mode. DFU Mode is similar but nothing displays on screen.
     
  3. hypotc thread starter macrumors member

    Joined:
    Mar 7, 2012
    #3
    Tried 3uTools aswell, it said that it was in DFU mode, but whenever I tried to flash the firmware it just lost connection with the phone. We ended up selling it to someone who wanted to fix it. :)
     

Share This Page