Crashing and beachballs in 10.7.5

Discussion in 'Mac OS X Lion (10.7)' started by Zeke D, Oct 26, 2015.

  1. Zeke D macrumors 6502a

    Zeke D

    Joined:
    Nov 18, 2011
    Location:
    Arizona
    #1
    Hello all, I'm hoping I don't have to reinstall Lion 10.7.5. I keep getting the following error when teleporting in Runescape:

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000178

    This doesn't happen when running in safe mode (holding down shift after chime), and it doesn't happen while running Windows 10 on the same machine, so I'm not thinking hardware issues.

    I'm also seeing the beach ball more often than I used to, and some apps are slow to load or close. I've done the normal disk permissions fix, delete start-up daemons, reinstalled the 10.7.5 combo update. Anything else I should try?

    I've attached the full crash file.
     

    Attached Files:

  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    First thing to try would be to check the HDD is OK. Download SMART Utility, extract and then run it - anything other than 'Passed' means your hard-drive is corrupted. As you're running Lion I've attached a Google Drive link for an earlier version of SMART Utility that will work on your OS.

    Click the download icon at the top to download this (highlighted below in red).

    3455.png

    If that passes, try verify the volume in Disk Utility. Does that come back clean?

    Just to also advise that it looks like it's crashing when using Java. Providing no problems were identified in the above troubleshooting steps, try download the latest version of Java here and then click 'Accept Licence Agreement' (highlighted in green) and then download the Mac OS one as highlighted in red.

    123.png
    Also try download this version of Java to see if this makes a positive impact.

    Then restart the computer with 'Reopen windows when logging back in' disabled. Does this fix the issue?
     
  3. Zeke D thread starter macrumors 6502a

    Zeke D

    Joined:
    Nov 18, 2011
    Location:
    Arizona
    #3
    Passed SMART, Passed verify. Downloaded and installed 8U65 JRE & JDK. Still the same issues. I'm starting to get beach balls when opening Word, and when clicking on the applications icon.


     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Oh boy this is weird. So you've also restarted with Reopen windows when logging back in disabled? What about PRAM/SMC reset?

    I hate to suggest it, but maybe update to El Cap and see how it runs (do Time Machine backup beforehand so you can restore to Lion if there's an issue)?
     
  5. Zeke D thread starter macrumors 6502a

    Zeke D

    Joined:
    Nov 18, 2011
    Location:
    Arizona
    #5
    Yes on the PRAM/SMC
    I'm running a 2006 iMac, so Lion is as high as I can go. Unless anyone else chimes in, I'll just do a reinstall from the lion recovery partition.
     

Share This Page