Crashing when clicking on a project

Discussion in 'Digital Video' started by professorjay, Jul 15, 2015.

  1. professorjay macrumors member

    Joined:
    May 13, 2007
    #1
    I worked on a project and everything worked fine. The next day, I open up Final Cut, click on the project to select it in the browser (not even double clicking yet to open it), and FCP immediately crashes.

    I have 2 projects with this problem, and I can no longer open them. Has anyone dealt with this problem? Any ideas on how to salvage them? I'm worried that work has all gone down the drain.
     
  2. professorjay, Jul 15, 2015
    Last edited: Jul 15, 2015

    professorjay thread starter macrumors member

    Joined:
    May 13, 2007
    #2
    Ok, after days of tinkering I found some random things that finally helped me save both in different ways.

    1. delete the CurrentVersion.fcpevent file in the project folder in the package contents of the library file
    2. open FCPX - you'll get an exclamation mark because it can't find it
    3. close FCPX and reopen it
    4. one project was selectable and openable; the other was selectable but would still crash after opening
    EDIT:
    Screw it, I thought I figured a way to open the 2nd project, but it's still crashing. Well at least I saved one of them so far.

    Also another weird thing is I closed and reopened FCPX, and the first project suddenly had a different name and it crashed when I tried to open it. After closing and reopening again, it had the original name and I could open it again.

    I had difficulty finding anyone online who had the same problem, but if you do, hope this helps.

    But after these issues, I am really nervous working in FCP X now. Luckily I had already finished both of these projects and sent them off. But I've been asked to provide a 2nd, slightly alternate version which led me to reopening them. I shudder to think if this happens when I'm still working in the middle of a project(s).
     
  3. musique macrumors regular

    musique

    Joined:
    Apr 10, 2009
    #3
    In the misery loves company category: I had a weird problem with FCPX constantly popping up a window – one which prevented me from working – telling me to connect to a server on my network. I'd taken the server off-line and FCPX wouldn't let me do anything without bringing that server back on-line.

    I made sure that nothing I was working on was on that server or even backed up to that server. I closed all the libraries. But, it still wanted that server available. I tried deleting the preferences/plists, to no avail. Eventually I deleted FCPX and reinstalled it. It continued to act this way until my Mac went to sleep one night, woke up, and decided it didn't need that server anyway. At least that's how it seemed.

    It's been fine for the past week or so, but this is the kind of thing that can scare the hell out of you. Next time I'll try this currentversion.fcpevent file. Thanks.
     

Share This Page