Crazy behaviour of my MBP - 4SNS/1/C 0000008:TAOP--124 " error

Discussion in 'MacBook Pro' started by guidoz, Mar 22, 2015.

  1. guidoz macrumors member

    Joined:
    Mar 7, 2014
    #1
    Long story short:

    -MBP 13" mid-2012 2.9Ghz, at a later stage (around mid/late-2013) upgraded with 16Gb ram, 256Gb SSD (samsung 840 pro), and optibay with original 750Gb HDD.

    -mid january 2015 I come back home after 3 weeks holiday to find my MBP (that had remained home) not working properly: fan runs crazily fast, system runs crazily slow. Further investigation lead me to notice "kernel_task" taking about 300% of CPU, and apple hardware test returns me a "4SNS/1/C 0000008:TAOP--124 " error.

    -I try a little bit of everything including restoring original optical drive, and testing my SSD externally on another MBP (working fine), or another disk with fresh install of the system mounted externally. I then send it for checks in a apple authorised repair (please note I live on a small and remote island 300kms away from first apple support, so it's not like I can take it anytime and within minutes or hours), but I keep my SSD home for privacy and safety of my data. They call me to ask what is wrong, because they can't find any problem (even after a 24h hardware test).. and eventually blame my SSD that I hadn't sent (but I know it works, at least externally, on other computer).

    -The computer comes back, I mount my SSD externally and it works. I mount it internally.. and back to usual problem. Mount it externally again.. still the problem (so it seems not to be the internal cable).

    - I decide to order a new SSD anyway (I might recycle one on my PC anyway), so I order a samsung 850 pro this time.. and well, even with brand new disk (although I had done, through another computer, a copy bit to bit from the old one) same problem. It's about mid february and a few days later I'm going to Milan.. so I decide to take it to apple there... but when I arrive there I talk quickly with the guy at the desk and he asks me to show him the problem... so I turn it on and... magic: it works! It was the 20th of February.

    -From 20th of February till 17th of March it worked just fine. Both with original optical drive and with optibay. On the 17th, I just turned it on again in the morning (I think I had actually left it on the night before, while listening to a podcast while falling asleep), and it started again with the usual problem... and it doesn't solve if I try without optibay. Tried again my ssd on another macbook (externally) and it works fine.

    -Both times I sent it for checks it worked. Both times it had the original optical drive mounted in, it had been turned off for days (so I tried now to let it "rest" for 4 days, but nothing solved of course), and had took a ride on a plane..... either it likes flying, or I really don't know....


    Any idea?
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    Sounds like your SATA cable has gone bad.
     
  3. guidoz thread starter macrumors member

    Joined:
    Mar 7, 2014
    #3
    Are you sure?
    You mean the cable of the ssd? In this case why it doesn't even work when mounted externally?
     
  4. guidoz thread starter macrumors member

    Joined:
    Mar 7, 2014
  5. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #5
    Since it works externally (except for once), let's assume that the SSD is all good.
     
  6. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #6
    That error is for the proximity temperature sensor for the optical drive. In your system, that sensor is usually part of the optical drive itself. In your case, it would be in your "OptiBay" unit. This is why you get that error when you test your modified system, but it goes back to normal when you put everything back to its original state.

    Replace the OptiBay, and your problem will likely disappear.
     
  7. guidoz, Mar 22, 2015
    Last edited: Mar 22, 2015

    guidoz thread starter macrumors member

    Joined:
    Mar 7, 2014
    #7
    Yeah I had figured out about the sensor but I wasn't sure it was in the optibay, although I suspected a link with it.

    I wish my system was going back to normality after removing the optibay. It is not going to normality, at least not immediately, maybe after some time.. But it seems random. All I know is the 2 times it went back to normal, I didn't have the optibay mounted (and had the otical drive).. But removing the optibay doesn't immediately and directly recover the situation (nor mounting it when everything is working immediately triggers the problem). Actually if I remember correctly, when my mbp came back from the first trip to apple and shortly worked, it did't have the optibay mounted.. And yet at second startup, minutes after the first successful one, it went back to the problem again... So I'm not totally sure I can blame the optibay (I'd be happy to just replace that and have everything working fine again!)

    Are you 100% sure the sensor indicated in the error message is related to the optical drive, or it was an educated guess? If it does relate, I have to underline i use the same drive cable both for the original optical drive and the optibay... What if the problem lies in the cable (although I think I had problems even with totally disconnected optical drive/optibay.. So nothing mounted on that channel)? I might surely buy a new cable, a new optibay, or whatever.. But I'd like to have high chances of succes before randomly spend to replace "innocent" parts of my mbp....

    Anyway, the sensor seems to be the key.. As both times the mbp was working, no error was found with AHT, and when not working I got the same error message even after a long time. It seems to be consistent. I've also read on the net the speedy fan and slowed down cpu might be a safety feature aimed at keeping the system cool when a temp sensor breaks and hence system temp is unreliable/undetermined. I just wish I could overdide this, as I think my mbp has no actual temp problem (the crazy behavior happens even after absolutely cold start).

    Thanks for your time!
    This problem is driving me crazy!
     
  8. guidoz thread starter macrumors member

    Joined:
    Mar 7, 2014
    #8
    I tried may times to turn it on these days.. and today it magically worked fine.... almost!

    no crazy fan, nor slow speed...

    but.... the key n o the keyboard is not working (I'm pasting it to write this message...)

    More ad more confused.

    I had tried yesterday night too.
    It was unplugged from electricity.
    I had the origial optical drive mounted in.

    Any clue?
     
  9. guidoz thread starter macrumors member

    Joined:
    Mar 7, 2014
    #9
    So it's bee already a week that it works properly, without optibay mounted... I think optibay might be the cause (I'll wait some more weeks without it just to be sure), although removing optibay doesn't immediately fix the problem (this is what quite confuse me).

    The n key problem is probably unrelated (although appeared just after last general problem), and maybe due to humidity (I live on a little island).. as when I checked it by removing the plastic "cap" of the key, I see something rust-coloured small spot on the circuit. At first I thought it could have been just dirt.. but it does look different from regular dirt (checked some other keys) and it doesn't seem to be removable.

    So, if all my last suppositions are right (otherwise must be the motherboard i'm afraid), do you think getting a new optibay might solve the problem forever, or any optibay might cause troubles again? I wanted to actually get a bigger disk (2TB) for my optibay... and if I can't it's a bit annoying.

    nobody with some kowledge/experience on the matter?

    Thanks

    Guido
     
  10. liveaspankaj macrumors newbie

    liveaspankaj

    Joined:
    Dec 14, 2015
    #10
    I had the exact same error.

    TA0P is for
    Ambient Temperature Sensor
    T = Temperature
    A = Ambient Temperature

    It is likely that your sensor is dead. OR, if you opened up the computer, you might have connected the connector in the wrong direction. I did not believe that it can be connected wrong way, but it did and I learned the hard way.

    And, the names on the the board are not visible when the wire is connected, because it is written below the wire near the connector.

    On Mid 2011, 27 inch this two wire connector (Ambient Temperature Sensor) is on the main board on the bottom left side near the fan.
     

Share This Page