Crazy Glitch

Discussion in 'MacBook Air' started by MacMacK77, Mar 6, 2016.

  1. MacMacK77 macrumors newbie

    MacMacK77

    Joined:
    Mar 6, 2016
    #1
    Ok so this may be something that no one has ever seen before i don't know.

    Anyways so about a year ago i spilt water on my laptop and obviously it paid its toll. I took the proper protocols letting it sit upside with a fan for days untouched before finally firing it up. Since that day the only thing wrong with my laptop is that my speakers don't work (having been using a bluetooth speaker to get around this problem) and sometimes my backlight doesn't go on and i have to reset the SMC. This isn't the crazy glitch.

    So here i am today on my laptop connected to Apple Tv over airplay streaming a sports game when all the sudden it disconnects from airplay and starts playing the game on my laptop screen with SOUND ON! I was shocked here i am a year without speakers working and out of no where they start going.

    Now it gets more complicated, as i started using my laptop with the speakers on playing music, my backlight kept tapping out and locking my computer. I simply had to click the mouse pad for it to come back and re-type my password but obviously this was a hassle. So I did what always seemed to work with the Mac and reset the SMC. Upon restarting i get the big start-up blare so again i hear sound, but as soon I logged in Gone again. Just like that i couldn't here my speakers again.

    So I ask if anyone as ever had a similar problem or knows any way to get my speakers to work. Obviously they are working it has to be some internal problem preventing them from playing, i don't know i'm no computer guy.

    Any help counts thank!



    Still so so shocked......
     
  2. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #2
    Have you ever reset NVRAM/PRAM? https://support.apple.com/HT204063

    After the display blacks out, does the system restart (do you see the Apple logo), or is it going to sleep (wakes directly to login)? If you're not sure, go to System Preferences > Security & Privacy, and un-check "Require password after sleep or screen saver begins." The idea is that if it's spontaneously restarting, it'll still ask you for your password, but if it spontaneously sleeps, it won't ask for your password.

    Change your System Preferences > Energy Saver preferences, too, see if switching the sleep interval makes a difference. Also, see if there's a difference between when you're connected to power or running on battery.
     

Share This Page