Crazy LAN problems with Age of Empires 3

Discussion in 'Mac and PC Games' started by Xenopathy, Jan 3, 2008.

  1. Xenopathy macrumors newbie

    Joined:
    Jan 1, 2008
    #1
    I had been playing AOE3 between my intel iMac and MacBook for some time with both running Tiger via an Airport Express. IIRC, after upgrading both machines to Leopard it was no longer possible to get them to communicate for the game. I have installed the latest patches from MacSoft, but these do not seem to do anything. I have tried to set IP and port overrides in the game options. The firewalls on both machines are configured to allow the AOE3 software access.

    After much playing around with the Airport settings, I eventually tried just running an ethernet cable between the machines and this worked for a while. Today, after about 45 minutes into the third game, the network just spontaneously quit without notice. It seems that the IP address on the MacBook changed autonomously(?) I have tried to set the IP addresses manually but with no luck.

    I'm not particularly network savvy, but also not completely thick. Can anyone suggest things to try? I have seen suggestions about port mapping/forwarding, but I am not sure if this is the problem.

    Many thanks!
     
  2. jakeguy99 macrumors regular

    jakeguy99

    Joined:
    Jan 21, 2007
    #2
    The IP joining and direct connect is bad and the game requires the most recent version for it to work properly. If you are using a "crack" because you 'dont' like using CD's just use A dvd since all updates require them and it will work fine.
     

Share This Page