Crazy problem with activating iphone 4...

Discussion in 'iPhone' started by clivewarren, Aug 10, 2010.

  1. clivewarren macrumors newbie

    Joined:
    Aug 10, 2010
    #1
    so after all this time waiting mine arrived today, and i just called to switch activation from my 3gs to the 4. It said turn the phone off for 5 minutes and i did so for 15 turned it on and it just told me to plug it into itunes. When i did it said i need OSX10.5.8 to use it. I have an iMac 5, 1, only two years old or so and i know that should be my OS. It seems when i brought my imac in to be fixed the guy downgraded my OS, so when i went to download 10.5.8 it wouldnt open because i dont have 10.5. My current OS is showing 10.4.9. Am i in real trouble here? I dont have a phone to call ATT with right now. Is there no way i can just download 10.5? Im certain this ran it before i brought it in to get fixed.
     
  2. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #2
    You need to purchase Leopard or higher. You can't just 'download' the OS unless you want to pirate the software (which I don't suggest).

    Snow Leopard is 30 bucks and will run on your Mac.
     
  3. tico24 macrumors 6502

    tico24

    Joined:
    Jun 17, 2007
    Location:
    Eastleigh, UK
    #3
    Just for the record, OS 10.5 was released October 26, 2007.
    10.6 came out August 28, 2009.

    Not sure what you mean by iMac 5, but the G5 came out in 2004, and the 5th iteration of the iMac came out in August 2007, so I don't think your computer was downgraded as you suggest.
     
  4. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #4
    The iMac 5,1 is the Late 2006 iMac (the first to feature Core 2 Duo processors).

    It came with Tiger, but can be upgraded to Leopard or Snow Leopard.
     

Share This Page