Crazy problem with Apple wireless keyboard.

Discussion in 'Mac Accessories' started by cosrocket, Aug 10, 2013.

  1. cosrocket, Aug 10, 2013
    Last edited: Aug 10, 2013

    cosrocket macrumors regular

    Joined:
    Jul 7, 2008
    #1
    Since yesterday i have a crazy problem with my aluminum apple wireless keyboard. I noticed that when I tried to type the @ symbol it would type the number 2, I then realized that when I would type any of the symbols on the numbers row with the left shift key held down it would only type the number, not the symbol. When I press the cap lock key the green light goes on and the letters will type in caps, but the symbols will still not register, only the keys corresponding #. if I hold down the right shift ket then the symbols will register.

    So, green light on cap lock does come on, letters will type in caps but not symbols. Holding down the left shift key neither cap letters or symbols will register but both cap letters and symbols will register holding down right shift key.

    Is this a problem with the keyboard or could it be some kind of glitch in Mountain Lion that is causing the strange behavior?

    I changed the batteries and unpaired and then repaired the keyboard but that did not help.
     
  2. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    It's normal for caps lock to capitalize letters but not provide symbols. It's "Caps" lock, not "Shift" lock.

    Sounds like your left shift key is kaput.
     

Share This Page