Crazy USB Drive Problem

Discussion in 'Mac Basics and Help' started by VaatiKaiba, Dec 26, 2010.

  1. VaatiKaiba macrumors 6502

    Joined:
    Jun 12, 2008
    #1
    So, I was lucky enough to get a new flash drive for Christmas, but I've run into a problem with it - namely, that all files put onto it seem to be unreadable. I have another USB drive which is basically identical (different brands, but same size, same formatting, same permissions, etc) in every way, which there's no problems with.

    Here's what I've done, and some stats about the drives:

    - Both 4GB
    - Both formatted in MS-DOS (FAT32)
    - The new (not working) one has been formatted on both Mac and PC
    - Files can be put on it alright, but can't be read (eg Pages can't read word docs, QT can't play movie files)

    I'm completely bamboozled, as I was trying to move a 2.5GB file across, and on the new drive it refused to play the file, while the old drive worked fine (so it's not a file problem).

    Does anyone have any other ideas as to how I could get this to work? Is it possible that it can only work on PCs?
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
  3. VaatiKaiba thread starter macrumors 6502

    Joined:
    Jun 12, 2008
    #3
    Well, it can be read by both computers, and both can see the files that are on it and put new files on... But once a file is put on it, it can't be opened by either computer.
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #4
    If you've already tried a full reformat, and it's doing the same thing on both computers, it sounds like the drive is just bad. Normally it'd just not work at all, but if the part that holds the directory data is ok, that behavior could well be the result. Have you tried selecting the hardware drive itself and using the Partition tab of Disk Utility to create a single partition, which will make sure to erase absolutely everything on the drive? This occasionally fixes formatting issues, though I wouldn't expect the symptoms to be what you're describing.

    You might try using Disk Utility to format it, and check "Zero Out Data" under "Security Options", just for the heck of it. Depending on what's acting up there's at least a chance that this'll fix it, although I'm not entirely sure I'd trust the thing after having problems like that.

    Incidentally, I'm assuming here that when you say can't be read, you mean you're getting read errors, not simple permissions errors.
     
  5. MacTribe macrumors member

    MacTribe

    Joined:
    Dec 26, 2010
    Location:
    London
    #5
    Formatting my work, but only if you've set the correct partition map. If you're using MS-DOS make sure you've set the partition to Master Boot Record, not GUID or APM..

    Let me know if that works for ya.
     
  6. VaatiKaiba thread starter macrumors 6502

    Joined:
    Jun 12, 2008
    #6
    Thanks for those guys, I'll have a look and let you know if I have any luck - your help is much appreciated!
     
  7. VaatiKaiba thread starter macrumors 6502

    Joined:
    Jun 12, 2008
    #7
    Right, so I've tried all the suggestions from both posts above (, and I've had an improvement. It's now moving photos fine, but still not the video file I was trying to transfer - which leads me to wonder if this is a file size issue? (200KB v 2.46GB)

    Is this possible? And is there anyway to solve that?
     

Share This Page