Create bootable High Sierra USB from Mojave

Discussion in 'macOS Mojave (10.14)' started by Dr. McKay, Jun 5, 2019.

  1. Dr. McKay macrumors 6502a

    Joined:
    Jan 20, 2010
    Location:
    Belgium, Europe
    #1
    I need to make a bootable flash drive with High Sierra. I have a 128Gb USB3 Toshiba flash drive, and I am running Mac OS Mojave on my iMac.
    I've managed to download the High Sierra installer and it is now in my applications folder.

    However, when I try to launch it, it says it is too old to be run on my computer (makes sense since I'm already on Mojave).
    But how do I go about it then ? I have no other external drive at my disposal, except for a 2Tb USB3 HDD which is partitioned into a HFS+ partition containing miscellaneous files, and a second partition for Time Machine. No way I can erase anything on that drive...
     
  2. Mr_Brightside_@ macrumors 68030

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    Toronto
    #2
    You should be able to use createinstallmedia in terminal
     
  3. MSastre macrumors 6502

    MSastre

    Joined:
    Aug 18, 2014
    #3
    Another option if you do not want to use terminal, is use Install Disk Creator to make your bootable installer.
     
  4. Dr. McKay thread starter macrumors 6502a

    Joined:
    Jan 20, 2010
    Location:
    Belgium, Europe
    #4
    Maybe I should clarify that I want to use that Toshiba flash drive as a Mac OS boot drive, to work on. I don’t just want an installer drive. I want to install High Sierra on it an be able to create a user on it, just like I would from my internal drive...
     
  5. benshive macrumors regular

    Joined:
    Feb 26, 2017
    Location:
    United States
    #5
    If you boot into internet recovery you can use disk utility to wipe the external drive and then install the version of macOS that was preinstalled on the iMac when it shipped. Then you should be able to boot into it and update to whatever version of High Sierra you want, given you're not already on it or just bought the iMac with Mojave preinstalled.
    I just used this method to install macOS Catalina on an external drive so that I can install iOS 13 on my phone but don't have to worry about messing with my MacBook's internal drive.
     
  6. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    OP:

    You didn't tell us which Mac you have.

    I don't believe you can run the High Sierra installer while you are booted up under Mojave...
    IF the Mac will boot from High Sierra, the following might apply:

    1. Create a bootable USB flash drive installer, as suggested above.

    2. Have a SECOND flash drive on-hand.

    3. Boot from the bootable flash drive installer. Connect the SECOND flash drive.

    5. Open the OS installer and "aim it" at the empty 2nd flash drive.

    6. Install a clean copy of High Sierra onto the flash drive.

    7. When the install is done, set up a basic account on the 2nd flash drive.

    You can now boot and run High Sierra from the 2nd flash drive, "right to the finder".
     
  7. Dr. McKay thread starter macrumors 6502a

    Joined:
    Jan 20, 2010
    Location:
    Belgium, Europe
    #7
    I have tried Install Disk Creator and took my chances with a 8 Gb USB2 flash drive I had lying around. High Sierra installer on the 8Gb flash drive, have formatted the Toshiba USB 3 drive as HFS+ Journaled, GUID partition table. Booted up from the 8Gb flash drive, have been able to launch the installer, but seems to be stuck. Only about a tenth of the progress bar has been filled, says 14 minutes remaining, but nothing is happening.
    Mouse pointer is not frozen, I can access the menu etc.
     
  8. Dr. McKay thread starter macrumors 6502a

    Joined:
    Jan 20, 2010
    Location:
    Belgium, Europe
    #8
    My iMac is a mid 2017 27 inch model, came with High Sierra installed. I also have a mid 2015 15 inch Macbook Pro, which had Yosemite as the original OS.

    I've tried with 2 USB keys, one USB2 with 8Gb which I used to create the installer, and the other USB3 128Gb key to install High Sierra on.
    The installer boots up just fine, but gets stuck halfway (not frozen, because when typing CMD-L, it says installation in progress). I left it there for over 2 hours, and nothing happens. Tried it on the iMac and on the Macbook Pro.
    I then wiped my Time Machine partition on the external 2Tb USB3 HDD (because I want to switch from a local TM backup to a networked one, connecting the drive directly to my router instead of the iMac, and local and networked TM backups are apparently not compatible) ; I put the High Sierra installer on the newly created partition and booted up the installer, no problem. I tried it this way because I thought the problem might be that my USB2 key is too slow.
    Unfortunately, it just stops at the same moment, with 14 minutes left (sometimes switches to 13 minutes). Left this one for 2 hours as well, but it just won't finish.

    Only thing I can think of is that there may be a problem with my Toshiba USB3 flash drive, but it seems to work just fine when I used it for other stuff...
     

Share This Page

7 June 5, 2019