Creating a new SMS from iMessage

Discussion in 'iOS 8' started by bbplayer5, Oct 20, 2014.

  1. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #1
    Each time I try to start a conversation with someone NOT using an iPhone, it tries to send them an iMessage. It gives me an error saying this number isn't activated for iMessage, and fails.

    If I start the conversation from my PHONE first, it syncs fine, and I can continue to participate in the conversation.

    Why can't I start an SMS conversation from iMessage on my mac? Why is it always trying to iMessage people who don't even have iPhones?
     
  2. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #2
    I sent a text just fine to a non-iphone user on yosemite's imessage

    when I sent first text it asked me to turn on sms relay did you get this?
     
  3. bbplayer5 thread starter macrumors 68030

    Joined:
    Apr 13, 2007
    #3
    Yes, its on. It works if I send a normal SMS from my phone first. I cant send an SMS to start a conversation from Yosemite.

    Phone number is not registered with iMessage - is the error.
     
  4. unobtainium macrumors 68000

    Joined:
    Mar 27, 2011
    #4
    I have the exact same issue. Finding Yosemite quite frustrating.
     
  5. ttmrn macrumors regular

    Joined:
    Oct 6, 2014
    Location:
    tx
    #5
    weird... i have no such problems.

    As soon as Message app figures it's not an iMessage email/number, it just turns green.
     
  6. fortheus macrumors regular

    Joined:
    Jul 11, 2012
    #6
    Make sure the iCloud email address is active in both device
     
  7. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #7
    i had to sign out of icloud on phone and mac then re-sign in on devices before hand off or continuity would work
     
  8. bbplayer5 thread starter macrumors 68030

    Joined:
    Apr 13, 2007
    #8
    I erased the iCloud account completely in the settings / internet accounts app. Erased anything dealing with iMessage in the keychain. Rebooted, added the account back, and it worked!
     
  9. tonixity macrumors newbie

    Joined:
    Oct 12, 2014
    #9
    You cannot send SMS with Messages on your Mac because they are not "supported". The only way you will enjoy the text sync between your iPhone and your Mac/Ipad is your correspondent to have an Apple Id.
     
  10. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #10
    With iOS 8.1 and OS X 10.10 Yosemite, this is incorrect. With these two operating systems, SMS syncs between devices just as iMessage does.
     
  11. fortheus macrumors regular

    Joined:
    Jul 11, 2012
    #11

    Unfortunately not. For sending out sms from Mac, iCloud email id must be active on both devices
     
  12. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #12
    The person I was replying to was saying that you cannot send SMS messages to a telephone number from your Mac, which is incorrect. It does appear that the OP is experiencing some sort of bug, which is not uncommon with this setup, from what I have experienced myself.
     

Share This Page