Creative WoW Headset - Error Messages

Discussion in 'Mac Accessories' started by rtdgoldfish, Mar 2, 2010.

  1. rtdgoldfish macrumors 6502a

    rtdgoldfish

    Joined:
    Jul 4, 2004
    Location:
    Jacksonville, FL
    #1
    Got my new wireless World of Warcraft headset over the weekend. Downloaded the software from Creative's site and installed it. Plugged in the USB receiver, synced the headset just fine. Now when I try to open the control pannel to configure the headset, I get a message saying "The audio device (headset) supported by this application cannot be detected. This application will now close."

    Anyone else out there have one of these headsets and getting similar errors?? The headset works just fine, I just can't use the control pannel to adjust any of the settings.

    Creative's support site offers no help for Mac users. Maybe I'll give them a call tomorrow if nobody has any suggestions.

    Thanks!
     
  2. blurstar macrumors newbie

    Joined:
    Jun 6, 2007
    #2
    According to your message, it may be due to the system requirements.. I have a look at the product on their site & it seems that for mac you will need os x v10.5 & above hope that helps.. by the way the product looks quite cool it will be good if you can have a review of it soon so I can consider whether to get it for my bf, he's a fan of wow :D
     
  3. rtdgoldfish thread starter macrumors 6502a

    rtdgoldfish

    Joined:
    Jul 4, 2004
    Location:
    Jacksonville, FL
    #3
    I'm on a brand new iMac running 10.6.2 so I know its not the system requirements. Seems like there are a lot of people on the Creative forums having issues as well. Hopefully they will update the Mac drivers/software soon. I'm really not happy about spending $160 on this product right now.
     

Share This Page