Critique on New Portfolio Site

Discussion in 'Web Design and Development' started by emorydunn, Mar 2, 2010.

  1. emorydunn macrumors 6502

    emorydunn

    Joined:
    Jun 5, 2006
    Location:
    Austin Texas
    #1
    Hi, I've spent the past, I'm not exactly sure how long, working on and off on a new website design and I've finally got it mostly finished. The only things left (hopefully) are putting copy in the site. So, without further ado, what does everyone here think?

    http://dl.dropbox.com/u/28756/Files/index.html

    I'm looking for mostly technical stuff, do links work, are there any bugs, etc. but also if you think there's a way the design could be improved then by all means let me know.
     
  2. MattSepeta macrumors 65816

    MattSepeta

    Joined:
    Jul 9, 2009
    Location:
    375th St. Y
    #2
    galleries

    The gallery thumbnails do not work properly. clicking a thumbnail only moves the image further left off screen.
     
  3. emorydunn thread starter macrumors 6502

    emorydunn

    Joined:
    Jun 5, 2006
    Location:
    Austin Texas
    #3
    Hmm… do you have JavaScript disabled? Just about everything on the site uses JQuery in some form. Also, could you post a screen shot?
     
  4. emorydunn thread starter macrumors 6502

    emorydunn

    Joined:
    Jun 5, 2006
    Location:
    Austin Texas
    #4
    Yeah, I'm going to ditch the frames. That was just the first way I got it to work. As for loading times that's another thing I know need to work on. Thanks.
     
  5. Macky-Mac macrumors 68030

    Macky-Mac

    Joined:
    May 18, 2004
    #5
    your gallery titled "personal exporations", should that be "explorations" with an "L" ??
     
  6. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #6
    The galleries don't work right in Safari 3. They scroll to the wrong places.

    Also, you may want to do some quick math and create gallery sections that fit into your width when you grow from 3 to 4. As it stands, if you added another gallery section, it wouldn't fit horizontally.
     
  7. emorydunn thread starter macrumors 6502

    emorydunn

    Joined:
    Jun 5, 2006
    Location:
    Austin Texas
    #7
    There is a new version up that fixes lots of little things, like spelling mistakes, as well as gallery thumbnail sizes.

    @decksnap, could you post a screenshot of what you mean? I don't have Safari 3 so I can't test it out.
     
  8. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #8
    I don't have it where I am now, but when it goes to the second image, it goes half again too far, so you see half of the second image and half of the third. When you go to the third one, they scroll all the way off the viewport altogether. Looks fine here in Safari 4.
     
  9. emorydunn thread starter macrumors 6502

    emorydunn

    Joined:
    Jun 5, 2006
    Location:
    Austin Texas
    #9
    That's very odd. I may have to try and build in some sort of failsafe for Safari 3.
     
  10. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #10
    I hate to say it but there's probably something more fundamentally wrong here than can be fixed by a Safari 3 workaround. I just tried it in FF 2 (mac) and the thumbnails and bottom nav don't even display at all.

    but then I just retried it in Safari 3 and it looks fine... so.
     

    Attached Files:

  11. emorydunn thread starter macrumors 6502

    emorydunn

    Joined:
    Jun 5, 2006
    Location:
    Austin Texas
    #11
    Shoot. I'll look into it a bit more. Thanks for the screen shots.
     

Share This Page