Cron backup was working, now fails due to invalid argument...PLEASE HELP!

Discussion in 'Mac Programming' started by VickyNesbitt, Dec 19, 2008.

  1. VickyNesbitt macrumors newbie

    VickyNesbitt

    Joined:
    Dec 19, 2008
    #1
    Hi I've had a cron backup running on a server machine for quite some time and it has worked flawlessly until this morning.....

    Here it is as it appears in crontab:

    MAILTO=myemailaddress@somewhere.co.uk

    30 8-18 * * 1-5 cd /Volumes/"Macintosh HD"/Library/"FileMaker Server"/Data/NEWBACKUPFOLDER; tar czpvf /Volumes/"Iomega HDD"/HourlyBackup/$(date '+\%a_\%H:\%M').tgz ./*

    So normally what I would get every hour is a file in the format DayOfWeek_Hours:Mins.tgz

    All of a sudden this morning my backups are failing with the following output:

    tar (child): /Volumes/Iomega HDD/HourlyBackup/Fri_10\:30.tgz: Cannot open: Invalid argument
    tar (child): Error is not recoverable: exiting now

    I've tried searching everywhere to find out more specifically what kind of error "invalid argument" points to or quite simply what it really means with no luck.

    Can you help pretty please?!?!

    Thank you

    Vicky
     
  2. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #2
    The first thing to check is the obvious. Can the file ri_10:30.tgz be created? Perhaps it exists already or the disk is full or permissions are wrong in the directory. Alway take error messages at literal face value as a first step.
     
  3. VickyNesbitt thread starter macrumors newbie

    VickyNesbitt

    Joined:
    Dec 19, 2008
    #3
    Yeah there is a ridiculous amount of space and permissions are good on both the source directory and the destination....There are no other files with that name and even so it would simply overwrite the original file which is what it does (or supposed to do) every week anyway.

    Literally it worked, now it doesn't.....can't figure it out....

    Now I have another issue on ANOTHER server!!!!!

    My archives wont unarchive...... apparently there is no such file or directory.... Why when clearly there is a directory and a file......?!?!??

    Any more ideas.....???
     
  4. johnjay1776 macrumors member

    Joined:
    Jul 25, 2008
    #4
    Drop to a shell prompt and attempt to run that date command that you have in cron from your shell prompt. What does it return? For some reason, it looks like your escape character isn't being picked up correctly ... Can you try it without the escape character and see if it gets your format correct?

    Additionally, make certain your volume is online and that the permissions are set appropriately all through your directory chain. I know you said it was earlier but have you checked the entire chain? Is the device mounted?
     

Share This Page