CrossOver Games crashing on startup

Discussion in 'Mac and PC Games' started by tomsabin, Jun 17, 2009.

  1. tomsabin macrumors newbie

    Joined:
    Sep 5, 2007
    #1
    Recently I installed PCSX2, a PS2 emulator for Mac and xquartz and CG framework (which were required), but I no longer wanted that emulator so I have uninstalled all of those files, well that I think, but now my CrossOver Games is no longer working

    I click on the application, it bounces on the dock and loads, a few seconds in it shuts itself down :S

    Can anyone tell me why it is doing this, it is very frustrating and I can't find a solution to it! Hopefully I won't have to reinstall the operating system to get it to work :/

    Thank you very much in advance!
    Tom
     
  2. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    Eh... first, does this PS2 emulator really work?!?

    If so, it sounds gr8!! :cool:

    But, back to your question.... are you sure you have really removed all the files?
    If I want to see what can be causing the crash of an app, I usually keep the "sys.log" alive during the start of such an app:
    Fire up Terminal.app (in /Apps/Utilities), and goto the log file directory (cd /var/log)
    Then type "tail -f system.log", and watch the log-file as you start Crossover Games.app... maybe you can be helped to look in the right direction.
     
  3. tomsabin thread starter macrumors newbie

    Joined:
    Sep 5, 2007
    #3
    I didn't have any games to test it with, but it looked like it would have worked anyway if you're interested - however I think it's still in a beta version.

    Thank you for you input, I'm trying to sort it out now, looks like I deleted some other files when removing the other components for the PS2 emulator. Reinstalling quartz-wm which is in the X11 bundle, I must have accidently deleted that because the log reports that it's missing those files.

    Jun 19 07:37:48 Macintosh ReportCrash[1355]: Formulating crash report for process quartz-wm[1360]
    Jun 19 07:37:48 Macintosh CrossOver Games[1345]: X client process terminated with status 5.

    It was crashing, but it wasn't showing the report afterwards.. but I guess all of this would have been in the crash report if I would have thought to look there :L

    Thank you very much MacsRgr8, I think this should solve the problem, i'll get back to the topic if it worked/didn't work
    :)
    Thanks again
     
  4. tomsabin thread starter macrumors newbie

    Joined:
    Sep 5, 2007
    #4
    I have recorded the log file when starting up CrossOver Games, and tried replacing the files which it says that are lost, but things are going no where :\. If anyone else has had this problem or has got a solution, it would be very appreciated.

    This is what I am getting as errors:

     
  5. HappyPig macrumors newbie

    HappyPig

    Joined:
    Oct 24, 2006
    #5
    Getting the same error

    I just breezed in from searching Google for a "X client process terminated with status 5" error I'm apparently also getting when trying to start up a Cider'd game. I've no solutions (that's why I came looking here) but I wanted to mention that I've the same crashing-upon-launch problems.
     
  6. AxxyBlaxxy macrumors newbie

    Joined:
    Apr 7, 2008
    #6
    So I returned to this forum after over a year, because I have something I'd like you to try.

    See what happens when you reinstall this older version on X11

    http://static.macosforge.org/xquartz/downloads/X11-2.3.2.dmg

    I've read that this is the latest version of X11 that Crossover supports, and the PCSX2 process overwrites it.

    Please let me know what happens. If it works again, I need to know so I can start screwing around with PCSX2 again.

    Thanks!
     
  7. starmanisjr macrumors newbie

    Joined:
    Jul 12, 2009
    #7
    Another weird crossover glitch

    I've only got the trial version of crossover games (v.7.2.2) but hopefully somebody might be able to help with this. I'm trying to play Half Life 2 ep. 1 but every 5 minutes or so my os completely crashes. The screen goes black and occasionally there's a looped sound clip from where the game crashed. I then have to do a hard reset.
    Anybody experienced something similar?

    btw now downloading X11 to see if that helps.

    Cheers
     
  8. aeror macrumors newbie

    Joined:
    Aug 4, 2009
    #8
    Thanks AxxyBlaxxy!
    The following worked for me:
    Open terminal. Completely remove X11:

    sudo rm -rf /Applications/Utilities/X11.app /private/etc/X11 /usr/X11R6 /usr/bin/open-x11 /usr/lib/X11 /Library/Receipts/X11User.pkg

    Install xquartz 2.3.2 following your link. Crossover Games works again!
     
  9. Pisslipz macrumors newbie

    Joined:
    Jan 2, 2010
    #9
    The link only works if you're running Leopard :(
     

Share This Page