Crucial M4 SSD disk error

Discussion in 'iMac' started by DennisMadsen, Jan 1, 2013.

  1. DennisMadsen macrumors regular

    Sep 21, 2010
    For about an year ago, I got an Crucial M4 SSD installed in my iMac (mid 2011) by an authorized Apple Mechanical. In the old Lion days, it was working absolutely perfect, but after I upgraded ti Mountain Lion there has been some issued with this disk.

    First of all, I was no longer able to enable FileVault on the disk. This is strange, as it works absolutely fine on my MacBook Pro (medio 2010) where I have replaced the HDD with a Crucial M4 SSD too.

    In the last couple of month, my iMac has been where unstable. I've experienced several times, that I cannot open applications (they never opens when I click the icon ) and sometimes I see an disk IO error in the Console.

    I've tried to repair the disk using Disk Utility both in OSX and in the Recovery Mode. But this get me this error:

    I'ved tried to restore the OSX from my Time Capsule and a couple of days ago I made a completely clean install of OSX Mountain Lion (I formatted the disk several times), but still I got the same error yesterday. I've updated the firmware on my SSD to version 040H, but this doesn't change anything.

    Does anyone have any clues on how to fix/repair my disk? Is there a way to completely reset the SSD?
    For me it sound like an corrupt disk, but sadly it is not very easy to replace the disk in an iMac.

    After doing the Repair Disk in Recovery Mode I'm no longer able to boot my iMac. I have to reinstall OSX.
  2. myuserid08 macrumors 6502

    Mar 15, 2008
  3. DennisMadsen thread starter macrumors regular

    Sep 21, 2010
    Yes, I think. I selected the drive in Disk Utility in Recovery Mode and choose "1 partition" in partition layout instead of Current and clicked Apply. I think that will erase the current partition table and create a new one?
  4. NVRENUF! macrumors regular


    Mar 19, 2012
    PERTH, Australia
    have you installed the older osx that worked before just to see if that works ?

    if it doesn't then i would say drive has just gone faulty.

    if it works fine with old os . then could be some compatibility issue :?

    not sure.
  5. natesymer macrumors newbie

    Nov 19, 2012
    New Jersey
    Have you updated the firmware? What firmware revision are you running?
  6. andrewkendall macrumors member

    Apr 30, 2005
    Did you ever find out more about this? I have an iMac with a Crucial m4 which is having similar issues.
  7. jmcgeejr macrumors 6502


    Oct 7, 2010
    Seattle, WA
    I had his issue, needed a firmware update to sort it out.
  8. B.A.T macrumors 6502a

    Oct 16, 2009

Share This Page