Crucial M4 SSD not showing as drive option for installing OSX 10.5.8 Leopard

Discussion in 'PowerPC Macs' started by VomaRecords, May 29, 2011.

  1. VomaRecords macrumors newbie


    May 29, 2011
    Any one else having problems using M4 or other solid state HD as a boot drive? Any solutions? I Have a Powermac G5 dual core (2.3) - Tried the following and still does not show as an option to install OSX from DVD software:

    SSD not recognized in your (Mac):


    Here are the steps that our performance testing lab took when installing OSX on the SSD:

    1. Once the SSD has been installed, ensure that the ribbon cable and the SATA interface cables are attached properly to the drive and also verify it is seated into the motherboard/pcb. This is very important, we receive several calls every week where the cables were the problem.

    2. Install OSX Disc 1 and wait until it asks you which disk you want to install the OS to. The SSD will not show up here! The drive comes without a partition, and needs to be reformatted/partitioned for the OSX before the installation disc can recognize it.

    3. Select Utilities and then select Disk Utilities.

    4. The Crucial SSD will show up in the Disk Utility (if it doesn't, power down and check both ends of the SATA cable again). Highlight the SSD and click the Partition tab.

    5. Click on Options and verify that it's set to "GUID Partition Scheme".

    6. Now select Partition 1 if you want to use the entire SSD as a single partition, and give it a suitable name.

    7. Verify that it has default selected "Mac OS Ex tended (Journaled)".

    8. Select Partition. The drive will now be partitioned and formatted.

    9. When the Disk Utility is done, close it.

    10. You should now be back on the screen where you can select a destination to load the OS, and this time the SSD will show up there. Select it, and continue with the install.
  2. ahollywoodcraig macrumors member

    Jan 2, 2007
    I'm not 100% sure but I think the drive has to be formatted Apple Partition Map not GUID. I could be wrong.
  3. Nameci macrumors 68000


    Oct 29, 2010
    The Philippines...
    On a powerpc it should be "apple partition map" rather than GUID, GUID is for intel macs only.
  4. burnout8488 macrumors 6502a

    May 8, 2011
    Endwell, NY
    It should say right underneath GUID, APM, and MBR what their uses are. (Intel, PPC, X86)
  5. zen.state macrumors 68020


    Mar 13, 2005
    Both PowerPC and Intel Macs can use drives in both formats. The restrictions are for booting only. PowerPC systems need Apple Partition Map to boot from and Intel systems need GUID.
  6. adcx64 macrumors 65816


    Nov 17, 2008
    Couldn't have said it any better!
  7. VomaRecords thread starter macrumors newbie


    May 29, 2011
    Tried Apple partitioning - journaled, unjournaled, - nothing works.
    Wrote zeros to the drive, everything - now the drive is not showing up at all.
    Talked with Crucial, their customer service is good, but they obviously cannot test on all computer types so they couldn't confirm what was up with the drive except to reset the firmware and try on a different computer to see if different result.

    For me, I'm a musician and audio engineer - not computer technician. I need something that is dependable and reliable, so I am returning this ssd for a 75GB Velociraptor HDD. If the audio glitching does not go away, then I'm going to conclude that I have to upgrade the processor, which means getting a new computer ... maybe go back to pc.

    Thanks all.

Share This Page