Resolved Crucial M4 SSD will not mount! [edited]

Discussion in 'Mac Apps and Mac App Store' started by hakuin, Sep 12, 2012.

  1. hakuin, Sep 12, 2012
    Last edited: Sep 13, 2012

    hakuin macrumors regular

    Joined:
    Jul 30, 2010
    #1
    I am trying to mount my SSD so I can update the firmware. Unfortunately the SSD will not mount/be detected at all. Is there any technique or application that will help? All suggestions welcome, including using Windows to do this.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What exact SSD in what exact Mac or enclosure do you want to mount? Have you tried Applications / Utilities / Disk Utility yet?
     
  3. hakuin thread starter macrumors regular

    Joined:
    Jul 30, 2010
    #3
    Sorry, it is a Crucial M4 256GB in a late 2011 MacBook Pro. This could be the known problem where the drive stops working after 5000 or so hours of use, which is resolved by an update to latest firmware. Unfortunately, it will not mount/be detected at all, either in the HD enclosure in the computer or in an external USB case. I have tried Disk Utility and TechTool Pro with no luck, and am running 10.6.8.

    Crucial have offered a replacement, but if I can fix it somehow I figure it would save me some time.
     
  4. hakuin thread starter macrumors regular

    Joined:
    Jul 30, 2010
    #4
    For future reference, I got it to mount by doing something similar to a "power cycle". Basically, I left it unplugged for a while. Since it could mount I was able to update the firmware. It seems to be working fine now.

    Firmware can be downloaded from Crucial website. Just unzipped to get the .iso file, opened Disk Utility and burned to a CD, then booted to the CD. Had to put the SSD in the internal HD enclosure to be able to update the firmware - could not be done with external USB case.
     

Share This Page