crucial m4 + trim support = fan running

Discussion in 'MacBook Pro' started by adamj575, Apr 11, 2012.

  1. adamj575 macrumors 6502

    adamj575

    Joined:
    May 17, 2011
    Location:
    Tennessee
    #1
    installed a crucial m4 ssd and then enabled trim support via the terminal and now my fan seems to be constantly running, well not constantly but alot and when doing very minor things...also have a speck see thru case installed....not sure which, if any, of these factors is contributing to the fan kicking on so often but any help would be welcomed!
     
  2. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #2
    Does iStat report any high temperatures while they are running? If not, then the fan controller may have gone a little rogue. I'm unsure how to remedy that though. Is the SSD firmware and all other mac firmware uptodate?
     
  3. lamboman macrumors 6502

    Joined:
    Aug 13, 2011
    #3
    Reset both the SMC and PRAM, this should fix the issue.

    TRIM or the m4 won't be causing the problem themselves.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    as about check stat, you might find the sad is reporting high temps which is causing the issue. i have a speck on my macbook and it caused no temp increase.
     
  5. fisherking macrumors 601

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    am not 'seeing' much difference with trim enabled (with an M4).
    try running without it, see how that goes.

    crucial says it's not needed, the built-in garbage collection is fine.
    on these (and other) forums, there are a lot of opinions on the subject.

    so i enabled it a few weeks ago, but again, doesn't 'feel' much different than before...
     
  6. adamj575 thread starter macrumors 6502

    adamj575

    Joined:
    May 17, 2011
    Location:
    Tennessee
    #6
    Yeah i agree with the trim comment....for me I dont think it is needed...so unless a problem arises down the road ill prolly just go without it...anyway on my problem i decided to just do a fresh install...all of my stuff is pretty much in the cloud anyway so its not nearly as big of a hassle as the days of old...hopefully it will fix an issue i was having with itunes match also (also posted in forum)....i did reset the pram and smc prior to the fresh install....hopefully everything will run like butter....thanks guys!
     
  7. lamboman, Apr 11, 2012
    Last edited: Apr 11, 2012

    lamboman macrumors 6502

    Joined:
    Aug 13, 2011
    #7
    Basically, TRIM won't make any difference for most users. Feel free to disable it; unless you are doing lots of heavy rewrites, it isn't entirely necessary.
     

Share This Page