Crucial SSD not recognised

Discussion in 'MacBook Pro' started by sofasurfer, Dec 16, 2011.

  1. sofasurfer macrumors member

    Joined:
    May 3, 2011
    #1
    Hi...I have a Crucial M4 SSD that is not being recognised by my mid 2009 MBP. When I run the Lion boot up program no drive is shown at all. I can swap the original HD back and all works fine.

    Crucial support told me that I needed to do this:-



    "In most cases, your SSD can be returned to normal operating condition by completing a power cycle. The process will take approximately one hour.

    1. With the SSD installed, power on the Mac and press the Option key to enter the Startup Manager.

    2. Leave it on the Startup Manager screen for around 30 minutes without using the Mac, then power off and disconnect the SSD altogether.

    3. After 30 seconds, reconnect the SSD and repeat steps 1 and 2 again.

    4. Power off, take out and reconnect the SSD and power back on.

    After the above steps, the SSD should be detected in the Mac again.

    If you do encounter any issues with this, or if you need any additional assistance or advice, please do not hesitate to contact us.

    Kind Regards, "

    However...this doesn't do anything and all I am left with is a blank grey screen.

    What is worrying as well is that the original HD has four small screws that keep the drive locked in place but the SSd doesn't have any screws at all and so the SSD is loose within the MBP.

    Can anyone help me out or is the drive DOA?
     
  2. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #2
    Do you not have the threaded screw holes in your SSD? I have a Corsair and the holes are there. Just take a Torx T6 and transfer the screws from your HDD to the new SSD.

    Did yo already format the SSD and load Lion on it?
     
  3. sofasurfer, Dec 16, 2011
    Last edited: Dec 16, 2011

    sofasurfer thread starter macrumors member

    Joined:
    May 3, 2011
    #3
    Got the screws in the SSD just need a T6...don't seem to have one.


    As for formatting the disc and putting Lion on it...I just booted from a Lion USB stick I created. The Lion install got to the point of where to install Lion and then it didn't even see the SSD.
     
  4. RBM macrumors newbie

    Joined:
    Dec 1, 2010
    #4
    After booting from the USB stick, open Disk Utility first and create a partition. You should be able to install Lion after that.
     
  5. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #5
    Agreed, the drive isn't seen as no partition exists on it. You have to prep it first for the install. The same thing would be true if it were a Windows Machine (although generally the bios may see the drive and Windows will do the format as part of the install.
     
  6. Steve's Barber macrumors 6502a

    Joined:
    Jul 5, 2011
    #6
    Yep. Disk Utility should pop up a message saying you need to "Initialize" the Crucial. After that... you're ready to format.
     
  7. sofasurfer thread starter macrumors member

    Joined:
    May 3, 2011
    #7
    Thank you everyone. The partition advice worked a treat and now I have a recognised SSD and am in the quite slow process of installing Lion on it.

    You have all been a great help. Merry Christmas:)
     

Share This Page