CS2 Indesign disappearing text

Discussion in 'Mac Apps and Mac App Store' started by Fank, Aug 25, 2011.

  1. Fank macrumors member

    Fank

    Joined:
    Jan 27, 2009
    Location:
    OH USA
    #1
    I purchased a 2010 imac with Snow Leopard on it last year. Recently I zero erased HD, re-installed Snow Leopard, and used migration assistant to move all programs and files from an older dual-core imac running Leopard, to the newer iMac running Snow Leopard.

    Everything copied successfully, (with the exception of a firewire network warning) and I started up the newer iMac with everything seeming to be running fine, no crashes, etc.

    I had cs2 on the old imac and a bunch of stuff made on it in Indesign. After relinking some files, everything seems OK there on the new iMac.

    I have a template up, and am typing text into a text box. After typing, I change to the cursor arrow or any other tool, and all the text in the box where I typed disappears until I double-click back inside the box to bring up the text tool again.

    Is this merely a glitch between Snow Leopard and Leopard that will only be resolved by upgrading CS2 to CS5 Indesign, or is there some other setting I can change to remedy that malady? The change from Leopard to Snow Leopard would seem to be the only variable.

    Any advice from the very knowledgable folks here at MacRumors appreciated.
     
  2. MacWorks macrumors newbie

    Joined:
    Aug 18, 2003
    Location:
    Minneapolis, MN
    #2
    Font Conflict?

    Sounds to me like a font conflict or corrupted font caches. I've been a Mac IT professional for more than a dozen years and the vast majority of my clients are the graphics/prepress industry -- in other words, they all use Adobe products. If I were called to your home/office to troubleshoot this issue, I would immediately scrutinize the fonts and try to rule them out.

    To do this, look inside Hard Drive > Library > Fonts. Move ALL of the fonts out of there and into a folder on your Desktop for safe keeping. Or better yet, create a new folder next to the Fonts folder called "Fonts (Disabled)". Move the fonts from the Fonts folder to the disabled folder. This may result in a copy of the files -- that's fine, simply delete all of the fonts in the Fonts folder once the copy is complete. You'll need your admin password to do that.

    Then repeat this process for the fonts in your Home Folder > Library > Fonts. Once you've done this, reboot your Mac and see if the behavior changes. If it does, great! But what about your fonts? I'd recommend that you use Suitcase or some other suitable font management software to handle your fonts instead. The idea is that Suitcase and dynamically turn fonts on and off as needed and this helps keep the number of active fonts to a minimum and avoids such conflicts. Additionally, Suitcase will include a copy of Font Doctor that will allow you to analyze your fonts for corruption or other issues.

    If this doesn't help, feel free to move your fonts back into place and then try rebooting in Safe mode. To do that, shut the computer down, then immediately after turning it back on, hold the SHIFT key down and keep holding it down until you see a progress bar below the Apple logo appear or until the login window appears. When the login window appears, it should say "Safe Boot" in red letters. You may go ahead and select the restart button there (no need to log in). The safe boot will rebuild system and font cache files which will effectively repair any corruption that may exist in said caches.
     
  3. Fank, Aug 30, 2011
    Last edited: Aug 31, 2011

    Fank thread starter macrumors member

    Fank

    Joined:
    Jan 27, 2009
    Location:
    OH USA
    #3
    Them fonts, they're corrupted

    Thank you Christopher for your reply.

    After reading your response, I used the 'path of least resistance method' first, and started up in safe mode. After restart, I went back into the Indesign pages and entered some text, switched to a different tool, and back to text, other tools, etc.


    All is well, thanks for your help.

    Edit: problem returns occasionally, and ya, I'll have to figure out font conflicts to get rid of it completely it seems.
     

Share This Page