ctrl + right clicking. Way around this?

Discussion in 'Mac Basics and Help' started by audiokeeffe, Aug 18, 2010.

  1. audiokeeffe macrumors member

    Joined:
    Aug 18, 2010
    #1
    Ok, I've been using Mac for the last 3 years, and have always used a dell mouse. (couldn't stand the mac mouse) I have gotten used to the fact that I have to hold ctrl while right clicking and it hasn't been a problem for me.

    But now I'm curious, is there a way to turn this off, so that I can just right click without having to use my left hand to press ctrl?
     
  2. SilentPanda Moderator emeritus

    SilentPanda

    Joined:
    Oct 8, 2002
    Location:
    The Bamboo Forest
    #2
    While you're probably trolling, you only have to press ctrl to right click if you have a one button mouse. You can right click without holding down ctrl so long as you have multiple buttons.
     
  3. audiokeeffe thread starter macrumors member

    Joined:
    Aug 18, 2010
    #3
    What are you talking about? Why would I be trolling...?

    I have a dell mouse with two buttons, but it still requires me to press ctrl at the same time.
     
  4. Cboss macrumors 6502

    Joined:
    Dec 11, 2008
    Location:
    Colorado
    #4
    Try going to System Preferences -> Mouse and see if there are some settings you can change in there.
     
  5. lewis82 macrumors 68000

    lewis82

    Joined:
    Aug 26, 2009
    Location:
    Totalitarian Republic of Northlandia
    #5
    Throw it in a garbage bin, then. I have used cheap-o mice with my iMac G3 and with my MBP, and all of them supported left clicks.
     
  6. maccompaq macrumors 65816

    maccompaq

    Joined:
    Mar 6, 2007
    #6
    I use Logitech and Microsoft mice, and the right click works exactly the same on my Macs & my Windows computers.
     
  7. Sayer macrumors 6502a

    Sayer

    Joined:
    Jan 4, 2002
    Location:
    Austin, TX
    #7
    Just sounds like the Right mouse button is set to be a default left button. Open your Mouse prefs and check. That sometimes happens with third-party mice or even Apple mice by default.
     

Share This Page