CUPS and printing

Discussion in 'PowerPC Macs' started by SecretSquirrel, Feb 15, 2016.

Tags:
  1. SecretSquirrel macrumors member

    Joined:
    Jan 21, 2013
    Location:
    U.K.
    #1
    Just before Christmas, our printer broke so we bought a new Canon MG5650. Good printer and installed fine with Canon drivers on the Macbook. Only got round to sorting the Powerbooks last week. Tried the 12" first with Tiger on it. After faffing around for a while with the last supported version of Gutenprint I finally gave up and admitted that there weren't any printers close enough in Gutenprint's profiles to fit. As a last resort, I downloaded the source code for the latest version and thinking I've nothing to lose, compiled it. The make command produced a load of warnings which didn't leave much hope but I went ahead and did 'make install' not really expecting much...

    Was shocked to my socks when I went to the System Preferences pane and found that not only was the printer found, it automatically installed Gutenprint + CUPS drivers for that very model! Thought I was on a roll so did a quick print of a test page with some text and a few icons. The text came out fine but the colours on the icons were dark and really dull.

    Using TFF, went to the CUPS server web page localhost:631 to see what could be done. Tried printing the CUPS Test Print and it came out perfect with text and colour wheel bright, vibrant and clear. So now I'm stuck - the CUPS test print is fine but printing from Pages messes up the colours. I even tried changing the colour model in CUPS like I did previously to fix a similar problem but it doesn't seem to help. Any ideas anyone?
     
  2. Hack5190 macrumors 6502a

    Hack5190

    Joined:
    Oct 21, 2015
    Location:
    Stuck on Earth in the USA
    #2
    This is good news. What version of Xcode did you use to compile the code?

    I have an HP OfficeJet Pro 8600 that's (unfortunately) not supported by Gutenprint 5.2.11 :(
     
  3. SecretSquirrel thread starter macrumors member

    Joined:
    Jan 21, 2013
    Location:
    U.K.
    #3
    Last one for 10.4 - I think it's 2.4.1
     
  4. Hack5190, Feb 15, 2016
    Last edited: Feb 15, 2016

    Hack5190 macrumors 6502a

    Hack5190

    Joined:
    Oct 21, 2015
    Location:
    Stuck on Earth in the USA
    #4
    Now that you have compiled it and it works (thats kind of the important part :)), are you willing to redistribute so others won't have to compile the source?
    FYI: The above is from this link http://gimp-print.sourceforge.net/reference-html/c39.html
     
  5. SecretSquirrel thread starter macrumors member

    Joined:
    Jan 21, 2013
    Location:
    U.K.
    #5
    Ok - I fixed it. Somewhere in the trial and error I made changes in CUPS but didn't implement them. By selecting KCMY instead of CMYK, the colour issue is fixed.

    In theory I'd be happy to package but the truth is I don't know how. Maybe someone more knowledgeable would like to have a go? I'll try to find out what's involved when I get some space.
     

Share This Page