Currently on 3.1.3 JB - should I upgrade to 4.2.1

Discussion in 'Jailbreaks and iOS Hacks' started by jackryan57, Jan 19, 2011.

  1. jackryan57 macrumors regular

    Joined:
    Nov 29, 2008
    #1
    I currently have a 3Gs running 3.1.3 - it is jailbroken and running fine. I have mywi running perfect and have the proswitcher working nicely on it.

    Here's my question - I'm bored and thinking about upgrading to 4.2.1 just to have a project to do. Is it worth it?

    I keep getting an error when I try installing some newer apps saying I need to be on the 4.0

    I'm looking for advice - pro's and con's

    Thanks guys
     
  2. err404 macrumors 68020

    Joined:
    Mar 4, 2007
    #2
    Most JB apps have been updated to support 4.x, including MiWi. Keep in mind that you may need to pay an addition $10 for the MiWi 4x update. AFAIK ProSwitcher will NOT work under 4.x

    Unless you can't go without ProSwitcher or don't want to invest in the MiWi update, you should upgrade. However, you may not want to upgrade to 4.2.1 since the untethered hack is still in beta. I'd recommend going to 4.1 until there is an official untethered JB.
     
  3. jackryan57 thread starter macrumors regular

    Joined:
    Nov 29, 2008
    #3
    Any idea where to find the 4.1 firmware and what would I do use redsnow?
     
  4. Grayburn macrumors 68000

    Grayburn

    Joined:
    Jul 12, 2010
    Location:
    London, England
    #4
    I've regretted updating to 4.2.1. and wish i stayed on 4.0.1 as i'm missing what the jailbreak brings to the phone.

    Gonna dive in and do the teathered Jailbreak tonight, can't wait until the unteathered Jailbreak comes out, when ever that will be!

    So i would stay with it for a while mate.
     
  5. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #5
    You can only go to 4.1 if you have the SHSH saved. Redsn0w 0.9.6rc7 will work to jailbreak on 4.1
     
  6. err404 macrumors 68020

    Joined:
    Mar 4, 2007
    #6
    You can get it directly from Apple here:
    iPhone3,1_4.1_8B117_Restore.ipsw
    You can use GreenPois0n or Redsnow for the JB. Personally I used GP, but either should work fine.
    If you haven't already done so, you may want to grab tinyumbrella to save your SHSH. This will be useful if you need to rollback the update.
     
  7. jackryan57 thread starter macrumors regular

    Joined:
    Nov 29, 2008
    #7
    I have my blobs saved - does tiny umbrella preserve my baseband? For any future unlocks?
     
  8. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #8
    Only IP4. If you wish to keep your current baseband, always upgrade using a custom firmware file (one that keeps your baseband). Thus, if you want to go to 4.1, use 4.1 custom firmware.

    Also, if you have old bootrom 3GS, you can have untethered JB on 4.2.1.
     
  9. jackryan57, Jan 19, 2011
    Last edited: Jan 19, 2011

    jackryan57 thread starter macrumors regular

    Joined:
    Nov 29, 2008
    #9
    Where do I find custom 4.1 or do I have to make it? ugh...I'm getting confused hahaha
     
  10. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #10
    When a custom firmware is being made, you can select whether it will update or not update the baseband. To know which one it is, read the description? And, do you have 4.1 SHSH files saved?

    Use pwnagetool to make one or find using google (from trusted site).
     
  11. jackryan57 thread starter macrumors regular

    Joined:
    Nov 29, 2008
    #11
    God, I cant even download pwnagetool??? wtf???
     
  12. SavMBP15 macrumors 6502

    Joined:
    Mar 26, 2010
    #12
    That is incorrect.

    If you have a 3GS made before week 39 then you can do an untethered jailbreak on 4.2.1. Lots of misconceptions about this.

    Do 4.2.1 on your 3GS. No issues other than use Pwnage to create a custom IPSW in order to preserve your baseband.

    Good hunting!
     

Share This Page