Cursor freezing and multiple keystrokes

Discussion in 'Mac Pro' started by steve18, Oct 24, 2018.

  1. steve18, Oct 24, 2018
    Last edited: Oct 24, 2018

    steve18 macrumors newbie

    Joined:
    Mar 10, 2006
    #1
    Mac Pro 3.1 2.8 GHz 8-Core - A1186 MA970B/A Early 2008 24GB RAM

    Wired USB mouse connected through Apple full size keyboard. Mouse and keyboard work perfectly on my other Mac Pro (1.1) running 10.6.8 and have done for years.

    Mac shows usual desktop after booting and usually results in the stuck cursor. Sometimes the keyboard and mouse have no power, other times they do. When they work I move the mouse 1mm and after a few seconds the cursor moves quite a large distance across the screen (the cursor also sometimes disappears and reappears somewhere else). When I try to input text one keystroke results in 7 x that character autofilling. Means I can't sign in as admin to try to sort this out. If I try to click on any finder menu it drops down and immediately disappears so can't select anything.

    I've only had this mac for 2 days during which it worked ok. After connecting to the net for the first time I opened Chrome and about 5 small pop up windows appeared. I just closed them without thinking but later thought they may be malware or a virus so I then downloaded Avast free for mac and did a scan. The next time I booted the problem started and have to hard shut down everytime.

    Things I've tried:

    1. PRAM reset
    2. Reset SMC
    3. Safe mode restart
    4. Unplugged all leads before booting again.
    5. Connected mouse direct into mac (every USB port).
    6. Used another wired non mac keyboard. Message then appeared saying bluetooth keyboard could not be found!
    7. Looked for hours online for a solution!

    Any help appreciated.

    Update -
    Deleted Avast after starting from external HD but cursor still not working properly. Very small movement of mouse results in a large movement of cursor after about a second delay. Keystrokes still autofill 7 times and can't select from menus.
     
  2. AliGT83 macrumors member

    Joined:
    Jul 17, 2018
    #2
    Have you tried a fresh macOS installation to rule out a software issue?
     
  3. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    To be honest it sounds more like system lag rather than an issue with your keyboard and mouse. I suspect there might be something hardware related, though it's always worth trying a fresh OS install to rule out that possibility.
     
  4. steve18 thread starter macrumors newbie

    Joined:
    Mar 10, 2006
    #4
    Thanks for the replies. As the mac came with no system disk I'll have to find one before trying a fresh install. This is easier said than done!
     
  5. steve18 thread starter macrumors newbie

    Joined:
    Mar 10, 2006
    #5
    Update

    I read somewhere that importing files from another mac using migration assistant can cause problems so I'm in the process of using another internal HD with a bootable system to delete everything off the offending HD and start again.

    I have 10.9.5 on the 3.1 mac pro with the problem but it didn't come with installation disks.

    I ordered a bootable USB stick with 10.10.5 to install on another internal HD I bought but it wasn't recognised by the mac (circle with diagonal line across, denied)! It said it was compatible so I have to try and return it and get another and try again. Never had a problem take so long to solve in 20 years.
     
  6. orph, Nov 4, 2018
    Last edited: Nov 4, 2018

    orph macrumors 68000

    orph

    Joined:
    Dec 12, 2005
    Location:
    UK
    #6
    you can just get osx10.10.6 from apple
    https://apple.stackexchange.com/questions/309399/how-can-i-download-an-older-version-of-os-x-macos

    the link from that topic>
    https://itunes.apple.com/app/os-x-el-capitan/id1147835434?mt=12

    thats going to be faster and safer than buying some random USB stick on ebay :confused:
    --- Post Merged, Nov 4, 2018 ---
    you may also want to look at this for fun
    https://forums.macrumors.com/threads/macos-high-sierra-10-13-unsupported-macs-thread.2048478/
    my 3.1 is still on osx10.10 but im tempted to stick 10.13

    edit as a side note it is worth swamping mouse and key bored if you have a spare around to see if it changes anything (even just for luck)
     
  7. steve18 thread starter macrumors newbie

    Joined:
    Mar 10, 2006
    #7
    Thanks for the reply.
    I have 2 mac pros, a 1.1 running 10.6.8 and a 3.1 I'm trying to install 10.10.5 on (the problem). The superdrive doesn't work on the 3.1 but I do have an old external drive that might work if I could get a dvd version of 10.10.5. Tried a different keyboard with no success.
     
  8. AliGT83 macrumors member

    Joined:
    Jul 17, 2018
    #8
    There was no, and there is no DVD version of Yosemite. It was only distributed via MAS. Download it and create a USB key with createinstallmedia

    Or do this for DVD

    https://discussions.apple.com/thread/6619535
     
  9. steve18 thread starter macrumors newbie

    Joined:
    Mar 10, 2006
  10. steve18 thread starter macrumors newbie

    Joined:
    Mar 10, 2006
    #10
    The 3.1 has a defective battery holder which shows the wrong time on start up but fixes itself after about 20 sec, I guess this is the reason I can't boot from the USB. This is the next thing to investigate.
     

Share This Page

9 October 24, 2018