Cursors Gets Stuck in Drag, Will Not Drop - mouse & trackpad

octoberstar

macrumors newbie
Original poster
Dec 1, 2010
3
0
Hi everyone,

Just in time for my final project in design studio: I am no longer able to drag and drop. I can't drag a file from one folder to another or to the trashcan. I can't pick things up and move them in any application, such as Photoshop or Illustrator.

When I attempt to drag something, I click, the cursor picks it up, and then... I can't drop it anywhere. Everywhere I move the mouse, the object or icon goes. Nothing I do will make it drop. I have to command+option+esc to open up Force Quit. Once I force quit the application I initiated the drag in, the problem goes away.

The problem is not associated with the trackpad. It persists even when using my old USB mouse and with my mighty mouse. I have all one-touch settings turned off. See attached screen caps of my trackpad, mouse, and universal access settings.

Please help! I can't do any design work without dragging!

- octoberstar
 

octoberstar

macrumors newbie
Original poster
Dec 1, 2010
3
0
Please see my second post for screen caps.

Also, I realized I forgot to give my model: MacBook Pro 2008 model, v 10.6.4, 2.5GHz, 4GB Ram.
 

valdevi

macrumors newbie
Jul 20, 2009
1
0
Cursor Drag

My MBPro is less than 6 mo old and i have had the problem of the drag getting stuck since i got it. i've taken it to 2 genius geeks in 2 different cities and they could not figure it out...said they've never seen the problem.
From what I've read this problem has been going on now for 4 years!
Hey if any of you Mac specialized trainers see this, please plea for us!
It'd s real drag mac hasn't fixed this yet.
 

chrfr

macrumors G3
Jul 11, 2009
9,665
3,523
My MBPro is less than 6 mo old and i have had the problem of the drag getting stuck since i got it. i've taken it to 2 genius geeks in 2 different cities and they could not figure it out...said they've never seen the problem.
From what I've read this problem has been going on now for 4 years!
Hey if any of you Mac specialized trainers see this, please plea for us!
It'd s real drag mac hasn't fixed this yet.
What version of the operating system are you using? The Magic Trackpad update that came after 10.6.4 caused issues like that. Updating to 10.6.5 or 10.6.6 solved it.
 

krspond

macrumors newbie
Jul 25, 2012
1
0
I know it sounds dumb...

I had this problem. For me, I discovered that the problem was being caused by leaving my Magic Mouse on while it was in my backpack and in close proximity to my MacBook. I would move the bag and something would click it and cause it to stay down in the drag position. I know it probably isn't your issue, but I thought I'd mention it just in case.

-KRS
 

adambyte

macrumors newbie
Jan 21, 2013
1
0
Me too! Fun!

I love coming to a forum and finding the exact same obscure problem that I am having, only to find that nobody has managed to solve it even years later.

And so now I am here, having the same problem. Cursor gets stuck as soon as I drag something, and won't let go no matter what.

Restarts, shutting down, turning off the trackpad of my MacBook Pro when a mouse is plugged in... All sorts of stuff doesn't help.

And then, like magic, it will start working fine again, like voodoo.
 

chrisperro

macrumors 6502
Oct 24, 2009
306
1
canada
I love coming to a forum and finding the exact same obscure problem that I am having, only to find that nobody has managed to solve it even years later.

And so now I am here, having the same problem. Cursor gets stuck as soon as I drag something, and won't let go no matter what.

Restarts, shutting down, turning off the trackpad of my MacBook Pro when a mouse is plugged in... All sorts of stuff doesn't help.

And then, like magic, it will start working fine again, like voodoo.
by any chance you ever install air parrot? or any type of Airplay third party application
 

Ravaliya

macrumors newbie
Feb 11, 2013
1
0
Has anyone solved this problem yet? i'm getting the same problem and its driving me nuts. I'm on 10.8.2 on MacBookPro 15inch Late 2008.

Its happening across the OS when i'm moving files or even just clicking files to be honest. More annoyingly its happening in Photoshop, Illustrator, and InDesign which is really causing problem while i'm trying to work.

I'm about to crack and get a new iMac if I can't get this resolved its driving me bonkers.
 

rosz242424

macrumors newbie
Mar 5, 2015
1
0
I'm new to Mac and I just had this same problem while preparing for an important presentation. After trying a bunch of things I pressed F4 and chose another application.

It worked!!!!!

I was able to continue using the computer normally as I was before. I hope this is helpful to someone.
 

randyman

macrumors member
Sep 15, 2010
51
15
I found a solution on another thread ("drag n drop not dropping"):

Put your computer to Sleep and then wake it back up and it might resolve the problem. It did for me.
Perfect! This has been driving me nuts for weeks – I’ll go for days just fine, and then it will crop up again.

I’ve been rebooting to get rid of it, but sleep/unsleep does the trick. Thanks!
 

drewbydoo

macrumors newbie
Feb 13, 2020
1
0
I dont think we deserve to have to sleep/unsleep our computers as a hack to make them perform the most basic functionalities properly. I have the newest 2020 16" mac and I've trouble-shot, A/B tested every device and setting that I can think of. I hope someone will post a real solution here. I'll to try to continue to research and post anywhere else this is discussed. This is a huge unnecessary problem nobody needs if they rely on their computer.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.