Custom Dictionary in Word 2008

Discussion in 'Mac Apps and Mac App Store' started by drawbridge35, Mar 26, 2008.

  1. drawbridge35 macrumors newbie

    Joined:
    Mar 26, 2008
    #1
    On my Intel Mac Book I started getting the message Custom Dictionary not available when I opened Word 2008 and so I couldn't add words. I finally deleted the custom dictionary and created a new one and the problem seems to have gone away. Strangely this problem hasn't occurred with the Word 2008 installation on my G5.
    Is this a bug or what?:confused:
     
  2. smart2k macrumors newbie

    Joined:
    Apr 18, 2008
    #2
    Try this on mactopia

    Edit - you'd already answered what I was looking for.
     
  3. Profdash macrumors newbie

    Joined:
    May 28, 2008
    #3
    Custom Dictionary

    I get a message that the Custom Dictionary is not available when I opened Word 2008 and so I couldn't add words. I deleted the custom dictionary several times, each time creating a new one, but the problem persists. Any ideas?????
     
  4. terryf macrumors newbie

    Joined:
    Jun 1, 2008
    #4
    Choose Word>Preferences>spelling and grammar panel. Click on Dictionaries Button, tick on Custom Dictionary you want to use. You can click on edit to make amendments.Your custom dictionary is located at user/Library/Preferences/Microsoft/Office 2008/Custom Dictionary.
     
  5. Profdash macrumors newbie

    Joined:
    May 28, 2008
    #5
    Custom Dictionary

    thanks that seemed to work.
     
  6. sjoerdsmink macrumors newbie

    Joined:
    Jul 31, 2008
    #6
    It seems to help if you don't select a language when creating a new dictionary.
     
  7. meeble macrumors member

    Joined:
    Jul 14, 2003
    #7
    I cannot get this to work. I don't have a Custom Dictionary file, and I've tried to create it - but nothing I do allows me to add words to it. Word keeps telling me that Custom Dictionary is not available.

    ideas?
     
  8. terryf macrumors newbie

    Joined:
    Jun 1, 2008
    #8
    Your custom dictionary is located at user/Library/Preferences/Microsoft/Office 2008/Custom Dictionary.
     
  9. terryf macrumors newbie

    Joined:
    Jun 1, 2008
    #9
    To add words to custom dictionary, go to word->preferences then click the spelling and grammar panel.
    Now click the dictionaries button,In the dialog box that opens, one dictionary is ticked.
    To review the list of words, click Edit.
    You can now review, add, delete and edit words in this custom dictionary.
    Make sure each word is on a separate line and press return after adding a word.

    Your custom dictionary is located at user/Library/Preferences/Microsoft/Office 2008/Custom Dictionary.
    :)
     
  10. macfanatic29 macrumors newbie

    Joined:
    Jan 2, 2008
    #10
    thanks

    Thank you!! :) i've been having this problem for a while now and i always figured that it was just full. But now its all fixed ;)
     
  11. budsimrin macrumors newbie

    budsimrin

    Joined:
    Sep 18, 2008
    Location:
    Fort Worth, TX
    #11
    "Add" is dimmed when I try to add words to custom dictionary

    I have tried everything. I even deleted all custom dictionaries using the Word 2008 preferences, Spelling and Grammar. I also deleted the default custom dictionary file in the Finder in case it was corrupt. I then used the Spelling and Grammar preferences to create a new custom dictionary. But, not only is "Add" dimmed when I try to add new words, but the custom dictionary itself does not appear in the Spelling and Grammar popup menu. It does shows up when I click on the Dictionaries button. :(
     
  12. terryf macrumors newbie

    Joined:
    Jun 1, 2008
  13. prob58 macrumors newbie

    Joined:
    Nov 10, 2008
    #13
    Custom Dictionary Not Available Fix

    Open word and select your preferences panel. Click on your Spelling and Grammar Preference and select your custom dictionary. Select "Remove" and confirm. Then select "New" and hit yes to confirm that you would like to add a new custom dictionary. This should eliminate your problem entirely.
     
  14. budsimrin macrumors newbie

    budsimrin

    Joined:
    Sep 18, 2008
    Location:
    Fort Worth, TX
    #14
    Thanks, prob58. I entered REMOVE but there was no CONFIRM dialog. I then selected NEW and used the default name, but again there was no CONFIRM dialog. Also, this did not solve the problems: ADD is still dimmed and the the custom dictionary pop-up menu is still empty.

    Actually, I HAD tried this earlier as well.

    Terryf suggested reinstalling, (and I had tried this, too) but I don't really know how to do this since there was no installation in the first place. The install disk simply says to drag the app to the applications folder. I did that, and it overwrote the existing app, but it didn't have any effect on anything that I could tell. Do I have to manually uninstall the entire Office 2008 package, locating all preferences, plug-ins, etc.? And then I lose all my settings in all the Office 2008 apps? I would hope there is some other solution like a corrupted pref file somewhere.

    As far as I can tell, everything else in Office 2008 works correctly.

    I appreciate all the suggestions. It is great to have a sounding board. Can anyone think of anything else? I am at a loss. :confused:




     
  15. swissmacuser macrumors newbie

    Joined:
    Dec 17, 2008
    #15
    Word 2008 Custom Dictionary "Custom Dictionary" is not available

    Hi

    I got the same bug and interestingly found the error causing the problem:

    my custom dictionary worked until the very moment when I added a particular word that included special characters. My word started with a # and a 4 digit number (which is used as an internal code of Endnote, an bibliography addon for MS Word). When I deleted the whole word with special character from the custom dictionary, then saving the custom dictionary, everything worked as before.

    So I recommend to check the content of the dictionary and scan for unusual words, delete them, and everything should work again. In principle the issue might also be solved by Microsoft: just allowing special characters to appear in the Custom Dictionary.

    Is there someone with similar problems/solutions?

    :rolleyes:
     
  16. budsimrin macrumors newbie

    budsimrin

    Joined:
    Sep 18, 2008
    Location:
    Fort Worth, TX
    #16
    Solved problem -- a different way

    I found my solution on another web site. It turns out that Office 2008 will not recognize a dictionary that is located anywhere other than on the boot disk. Those of us who use the Sandbox concept of the SuperDuper backup application have our user folder on a non-boot disk, and so Office 2008 doesn't recognize custom dictionaries in our user folder. The solution is to put the custom dictionary on the boot disk. I put mine at Library/Preferences.
     
  17. nyse4 macrumors newbie

    Joined:
    Jan 10, 2009
    #17
    Correct

    Swissmacuser you are perfectly right. I tried every suggestion in this forum but yours solved my problem - turns out the pound sign "#" and a number in one of my saved words seemed to be the culprit. Thanks for sharing you saved me days of frustration :)
     
  18. SuisseTB macrumors newbie

    Joined:
    Jan 18, 2009
    #18
    Nothing seems to work!

    I have tried every suggestion in this thread, as well as suggestions from a few other sites, and nothing is working. I have removed and made new Custom Dictionaries, stored them in a different place, etc., but the problem keeps coming back. While I have a bit of an usual case, the problem did NOT occur with Word 2004. Here is the situation: I have one particular document that I write each week in German (and I must have the German spell checker). Each week I just rename the same document with a different date for the next week, i.e. I do not start over with a new document each week. Also, because none of the people I send it to have Office 2008, this document is saved as ".doc" as they cannot view files with the suffix of ".docx". For that one document, the Language I have chose under Tools is German. Every other document has English (US) as the language chosen. (The Custom Dictionary has "none" chosen for a language, just as I did for Word 2004.)

    With Word 2004, there was just 1 Custom Dictionary, and it worked fine with any document (even doing the above). Word 2008 just can't seem to get along with this. If I delete the Custom Dictionary and make a new one, things are fine until I so much as open the .doc document that has German chosen as the language. This didn't matter in the "lower" version, so I just can't understand why it won't work now.

    Can anyone help? If the advice is to reinstall 2008, just how do I do that? (That same question was asked earlier in this thread but never answered.)

    I will go back to Office 2004 if I have to, but I paid a lot of money for 2008 and would rather not "waste" it. As I said, I have tried every suggestion I could find, but nothing works and am at my wits end. Can anyone help?!?!

    Thanks so very much!!
     
  19. benbryce macrumors newbie

    Joined:
    Jan 20, 2009
    #19
    I fixed mine

    Hi, I had very similar problems to budsimrin

    I opened user/Library/Preferences/Microsoft/Office 2008/ and dragged the custom dictionary onto my desktop (and later the trash).

    Once that was done, I opened Word. I chose Word>Preferences>spelling and grammar panel. There I "removed" the old custom dictionary and then a made a "new" one.

    That created a new file named "custom dictionary" in user/Library/Preferences/Microsoft/Office 2008/ and all was fixed.
     
  20. SuisseTB macrumors newbie

    Joined:
    Jan 18, 2009
    #20
    Tried that

    Well, benbryce, that was a good suggestion, but I have already tried that one - more than once! Thanx for trying, and I sure hope someone out there can help me!!:(
     
  21. akahoxta macrumors newbie

    Joined:
    Jan 28, 2009
    #21
    yes this advise worked for me to

    yes this advise worked for me to
     
  22. SuisseTB macrumors newbie

    Joined:
    Jan 18, 2009
    #22
    Not selecting a language

    I've tried that more than once as well. Nothing seems to be working! If I should reinstall Office 2008, what precautions should I take so as not to loose anything....or perhaps to reinstall Office 2004 - would ask the question even more strongly if did this!!

    Thanks, and I'm still keeping my fingers crossed for a solution!
     
  23. mrnabo macrumors newbie

    Joined:
    Aug 24, 2008
    #23
    Hi,

    Sorry to latch on to this thread, but I can't get Word to check my document in English for any spelling errors, it's as if the English dictionary was missing. I also need to check my documents in Spanish, but same problem.

    Reinstalling hasn't helped - anyone help me with this? (let me know if I need to start a new thread for this)

    Thanks
     
  24. Jakesandwich macrumors newbie

    Joined:
    Apr 7, 2009
    #24
    Document Can Cause Problem

    I recently had a similar problem, and it seems to have been started by a Word document that had French words included. When I ran the spell checker it caused the "Custom dictionary not available" error. I fixed it, but then when I ran the spell checker on the document, it happened again, seemingly wanting to switch to a French dictionary. I fixed it again by setting up a new custom dictionary, and as long I stay away from that document I don't have any problems.

    Perhaps people who work in two languages routinely may not be able to fix the issue?

    Anyway, hope this helps someone!
     
  25. SuisseTB macrumors newbie

    Joined:
    Jan 18, 2009
    #25
    RE: Document using 2 languages causing problem

    That is PRECISELY what happened to me. I tried every "fix" that has been posted here and elsewhere and could solve the problem until I opened the document with German words in it. I routinely use documents with German words in them AND I still really need a Custom Dictionary for English. There was never any problem with this using Office 2004, and I would dearly love to just go back to it. I have tried to do that, but then a problem with Entourage surfaces, and I cannot get the 2004 version to use or import all my addresses, emails, and calendar from the 2008 version (also having tried multiple things posted by others). I am at a total loss am hoping for guidance with either fixing the "Custom Dictionary Bug" in Office 2008 or being able to successfully go back to Office 2004 without losing everything from Entourage. Yes, I know where all the Entourage files are, and I even have them backed up, but I still cannot get the 2004 version to recognize or use the 2008 Main Identity. Pardon me if this has gotten long, but this problem has been going on for a long time, and I cannot seem to get any answers that work. Thank you!
     

Share This Page