Custom xterm in X11

Discussion in 'macOS' started by Attilla, Oct 28, 2007.

  1. Attilla macrumors newbie

    Joined:
    May 16, 2006
    #1
    'Morning


    I installed Leopard yesterday and everything workks fine. But one thing doesn't. I like to work with xterm in X11 (don't ask why) and I like my xterm to have a black background with white letters and some other settings.

    To get this I have to start xterm like this:
    xterm -sl 2048 -leftbar -sb -bg black -fg white

    And that works perfect, only I want to bind cmd + N to it like I had in Tiger. So I did that like this:
    [​IMG]

    But nothing happens when I press cmd + N. So I looked in the console and I found this:

    10/28/07 8:25:43 AM org.x.X11[2458] login: xterm -sl 2048 -leftbar -sb -bg black -fg white:
    10/28/07 8:25:43 AM org.x.X11[2458] No such file or directory

    Ofcourse it says no such file or directory, but when I manually start it, it works. Does anyone have the same problem or does anyone know how to fix this problem?
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    If you replace xterm with the full path to xterm does it work? How about without all the arguments?
     
  3. Attilla thread starter macrumors newbie

    Joined:
    May 16, 2006
    #3
    Without the arguments it works, but xterm only looks the first time at the xinitrc so I have to use arguments to get custom settings for the second time.

    I just included the whole path, but unfortunately that didn't change it.

    10/28/07 8:40:33 AM org.x.X11[2458] login: /usr/X11/bin/xterm -sl 2048 -leftbar -sb -bg black -fg white
    10/28/07 8:40:33 AM org.x.X11[2458] : No such file or directory
     
  4. Attilla thread starter macrumors newbie

    Joined:
    May 16, 2006
    #4
    Well, I made a workaround:

    Code:
    bash-3.2$ cat /usr/X11/bin/xterm-black.sh 
    /usr/X11/bin/xterm -sl 2048 -leftbar -sb -bg black -fg white
    I just call xterm-black.sh in X11 and then it works. So it seems that there is a bug with the arguments in X11.
     

Share This Page