CVS issues...

Discussion in 'Mac Programming' started by Soulstorm, Apr 29, 2007.

  1. Soulstorm macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #1
    I am trying to set up CVS on my machine and use it with XCode 2.

    I have successfully managed to set up a cvs repository and set the environment variable for it. I have followed this guide to do so. When reaching the point where I must use the 'cvs import -m' command, I get an error in the Terminal saying: "cvs [import aborted]: -t/-f wrappers not supported by this version of CVS
    A legacy version of cvs with -t/-f wrapper support is available as: /usr/bin/ocvs."

    I know this guide is made for an older version of XCode, and that the latest versions include an updated version of CVS, but even Apple's documentation uses this command to import a project!

    Can someone help me?
     
  2. savar macrumors 68000

    savar

    Joined:
    Jun 6, 2003
    Location:
    District of Columbia
    #2
    This isn't the answer you're looking for, but would you consider using SVN instead of CVS? SVN is younger and more powerful, CVS is getting long in the tooth.
     
  3. Soulstorm thread starter macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #3
    I thought of that, but for some reasons I am obliged to use CVS.
     
  4. szymczyk macrumors regular

    Joined:
    Mar 5, 2006
    #4
    Type ocvs instead of cvs to use the older version of CVS that supports wrappers.
     

Share This Page