Cyberduck SSH on public wifi port 22 blocking

Discussion in 'Jailbreaks and iOS Hacks' started by mayakukla, Aug 11, 2010.

  1. mayakukla macrumors regular

    Joined:
    Jun 14, 2010
    #1
    Can I go to Starbucks and use their att wifi and then use cyberduck? I believe they block port 22. Is there a way around this?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
  3. mayakukla thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #3
    what port would be open at a public wifi? And would open SSH know to listen for the other port?
     
  4. Bandolier macrumors 6502a

    Joined:
    Aug 2, 2010
    #4
    Be sure to use the IP Address in Settings>wifi>blue arrow and not the one in SBSettings. Sometimes they are different as I discovered the long way.
     
  5. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #5
    You can use any port. Example: 9754 To change the port on the server just edit the Services file in /etc/ just scroll down till you see "ssh" it's near 22. Then just change both 22's to the port of your choice and restart the server.
     

Share This Page