Cyberduck SSH ?

Discussion in 'Jailbreaks and iOS Hacks' started by Wicked1, Oct 29, 2010.

  1. Wicked1 macrumors 68040

    Wicked1

    Joined:
    Apr 13, 2009
    Location:
    New Jersey
    #1
    Ok so I have it loaded, and I am trying to connect via the ip address of my iphone with the username root and root password, but it will not connect, assuming it is port 22?

    I did this before but for some reason after reloading my MacBook I no longer have all my settings, so I am starting from scratch again, so I can use all the help I can get :rolleyes:
     
  2. iMaconApple macrumors 6502a

    Joined:
    Jun 30, 2009
    Location:
    Sunny Diego
    #2
    make sure you on SFTP...so i assume this is your first time doing this again..it takes like 30 seconds for cyberduck to read it for the first time again..just try it again
     
  3. jarjartee macrumors newbie

    Joined:
    Jun 12, 2011
    #3
    Cyberduck / Fugu / SSH

    Had big problems connecting with cyberduck on iphone 4. Tried any configuration under the sun, so downloaded Fugu, turned WPA security off and hey presto I'm in !! (iPhone4 - Greenpois0n 4.3.2) , used port 22

    OK here's the deal folks, turn of all security on router, connect Cyberduck/Fugu (both in turn if you've got them) - bookmark connection and Quit. Put security back on router - all works brilliantly . I have now tried this 3 times; computer on/off etc-seems to stick
     
  4. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #4
    This is silly.... WPA has NOTHING to do with SSH/SCP. The big thing to remember is to make sure both your iPhone and your computer are on the same network. Sometimes the iPhone won't connect to WiFi when it wakes up until after you go into something like Safari.

    Also, make sure you actually have the right address for the iPhone. If you are just using standard DHCP on your router, the IP can change.
     
  5. dudeabiding macrumors 6502

    dudeabiding

    Joined:
    Aug 24, 2009
    #5
    Did you re-setup your MacBook to allow SSH per #s 5 and 6? I have CyberDuck on my iMac and it runs perfectly. Make sure you are on WiFi, make sure you extend AutoLock to "Never," make sure you are on Homescreen, NOT Lockscreen, make sure you use correct address (which you can easily get if you have SBSettings installed).

    [​IMG] [​IMG]
     
  6. jarjartee macrumors newbie

    Joined:
    Jun 12, 2011
    #6
    OK silly might be, I am only reporting what actually HAPPENED to me, I'm fairly tech savvy - and I know that computers and networks behaves in erratic ways - it sometimes defies logic. If I could point out or quantify what the fault with my setup was at first I would share it immediately !!! As mentioned I tried all manners of advice posted on various forums by ' well-meaning wise guys ' - none of it worked. There is an awful lot of advice given on the basic setup of SSH and wireless connections (don't get me started on HP printers), most of it obvious and patronising - we really don't need this. Forums like this are choc full of real people with real problems, having spent good money on buying ill advised equipment - so we need their experiences and real solutions.
    If anyone can explain what happened to me in setting up SSH please do, I just know that for some reason when I switched security on my netgear router off - BOTH Fugu and Cyberduck connected to my iPhone 4 in turn !!!!! (I have always used static IP's for my WiFi connections)
     

Share This Page