Cyberpower UPS won't wake sleeping Mac Pro

Discussion in 'Mac Pro' started by 41qser, Mar 10, 2009.

  1. 41qser macrumors regular

    Joined:
    Sep 5, 2007
    #1
    I've performed dozens of searches to find an answer with no luck...

    mac pro: 2 x 2.66
    UPS: CYBER POWER CP1500LCD, USB plugged directly into MP, using OS X Energy Saver prefpane (no 3rd party programs)

    Everything is fine when the MP is awake and running normally.

    But if I sleep it, then kill power to the circuit the UPS is on, it won't wake up. If I unplug and replug the USB cable, it causes the MP to wake and the warning about power failure pops up.

    Any ideas? It's not a crisis as the MP will sleep on battery for quite a while... but I'd still prefer it to wake and shutdown gracefully.
     
  2. 41qser thread starter macrumors regular

    Joined:
    Sep 5, 2007
    #2
    work around

    Using the Deep Sleep widget, I've worked around this issue: I changed the default sleep behavior to Safe Sleep (hibernation+sleep).

    When I'm on the grid, my computer will now safe sleep after 3 hours of non-use.

    If I go off the grid and onto UPS while the MP is awake, the Energy Saver preferences will safe sleep after 1 minute. If for some reason this doesn't occur, Energy Saver will invoke a shut down after 5 minutes.

    If I go off the grid and onto UPS while the MP is safe sleeping, no big deal since contents are written to the HDD and RAM with this configuration.
     
  3. zfilipov macrumors newbie

    Joined:
    Jul 22, 2009
    #3
    Hi, I am wondering about the same issue. So by using this widget, everything will be fine if my iMac is in deep sleep mode if it loses USP power?
     

Share This Page