iPad Cydia apps crashing then disappear after respring

Discussion in 'Jailbreaks and iOS Hacks' started by RDAR, Jan 2, 2014.

  1. RDAR macrumors 6502

    Joined:
    Oct 23, 2012
    #1
    Some apps I got from Cydia include Movie Box, Music Box, MxTube, ProTube TrackImport. Sometimes they will all just randomly stop working/crash. I press on them to open it and it just comes back to the home screen. When I respring my device all the apps I mentioned above are gone from my home screen. I search for it on spotlight and they are not there. I have to go into Cydia, go to my installed section and press reinstall. They funny thing is I just press reinstall on one of them, lets say ProTube, and when I go to the home screen they are all back again. Does always reinstalling take up the space, because Movie Box is 8MB. Is there a way to fix this issue. I'm on iPad 4 7.0.4
     
  2. Applejuiced, Jan 2, 2014
    Last edited: Jan 2, 2014

    Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Did you check if any of those apps are compatible with the new JB and ios 7?
    I doubt they all are though and that's why you're having problems.
    Mxtube, supports 4.x, 5.x, 6x so you're surprised you're having issues with it on ios 7?
    Music box the same.
     
  3. JeReSpringer13 macrumors member

    Joined:
    Dec 23, 2013
    #3
    Try downloading Mobile Terminal and running the uicache command when they disappear. This usually works for me.
     
  4. RDAR thread starter macrumors 6502

    Joined:
    Oct 23, 2012
    #4
    Yeah MxTube is the only one that doesn't mention anything with iOS 7, but I have been able to use it perfectly. Even something like ProTube that says iOS 7 on the cydia page is supported. It just randomly stops working sometimes when I try to open it. I close it from the multitasking and reopen but it always crashes. And like I said at that point i would just respring but they aren't there. And these are just apps not tweaks.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Yes, but those other 2-3 packages that are not supported yet might cause issues and conflicts like that with other packages that are supposed to be working on ios 7.
    Start removing them one by one till you find what one or more than one that are giving you problems.
     
  6. RDAR thread starter macrumors 6502

    Joined:
    Oct 23, 2012
    #6
    ProTube was the first thing I installed when I jailbroke my iPad yesterday. On the Cydia page it says ProTube is compatible with iOS 7. These crashes were happening even when ProTube was the only thing I had installed from Cydia.
     
  7. RDAR thread starter macrumors 6502

    Joined:
    Oct 23, 2012
    #7
    Also the apps sometimes turn into this icon in the picture below when they stop working and keep crashing. It turns into like a white blueprint/target symbol.
    [​IMG]
     
  8. m8leo macrumors newbie

    Joined:
    Jan 27, 2014
    #8
    Just use I cleaner pro. To clean junk.
    On the toggle of cydia unused dependence.
    And tap clean. Then. Respiring. And ur done all affected cydia app comes back without reinstalling. Just follow the steps when ever e face the problem. Till some dev.or geek found bug fix.
     
  9. Mactroki macrumors member

    Joined:
    Nov 25, 2013
    Location:
    Paris, France
    #9
    Protube disappears from my springboard after a crash too.
     
  10. viperzc macrumors newbie

    Joined:
    Feb 4, 2014
    #10
    I was looking a solution cause I had the same problem, and actually I registered into the forum just to let you know what I did. It turned out to be Winterboards fault. Everytime I deleted an app from the appstore, the cydia apps in the springboard crashed, the icons turned into that white blueprint/target symbol you talk about, I tried deleting one by one of the cydia tweaks I had, testing everytime deleting appstore apps, and finally they stopped crashing when I delete Winterboard. Hope this help you.

    Greetings from Colombia
     
  11. RDAR thread starter macrumors 6502

    Joined:
    Oct 23, 2012
    #11
    Is this happening to anyone else????? My cydia apps always turn into these as the app icons and they always crash on startup and I have to respiring to get them to work.

    [​IMG]
     
  12. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #12
    try reinstalling one of the missing apps in cydia when that happens
     
  13. RDAR thread starter macrumors 6502

    Joined:
    Oct 23, 2012
    #13
    Yeah that is what I'm doing right now, I'm just wondering if someone else is having this problem because it is constantly doing this. I probably have to reinstall something at least 10 times a day. I want a permanent fix!
     
  14. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #14
    The last time it happened to me, I only had to reinstall once. My device has been perfectly fine ever since

    Did you restore from a backup?
     
  15. RDAR thread starter macrumors 6502

    Joined:
    Oct 23, 2012
    #15
    I restored my device when 7.0.6 came out and didn't do a backup just started fresh. I was on 7.0.4 it was fine but ever since I updated and jailbroke it always turns into that symbol.
     
  16. z06gal macrumors 6502

    Joined:
    Aug 30, 2011
    #16
    Saw this post over at Modmyi and it has helped a number of people:


    "MISSING PACKAGES AFTER UPGRADE/RESTORE TO 7.0.6 FIX

    This topic recently came up in #iphonedev on irc.saurik.com. I speculated that Cydia's cache got out of whack with the state of the packages that the underlying package manager (apt) knew about. The procedure to correct this is straightforward but will require you to tinker with some of the files the Cydia stores on your iOS device.

    I recommended the following steps, and it seems to have helped Tatsh.

    Cydia stores the "Release" files (the repository package lists) in /var/lib/apt/lists
    Make sure Cydia is closed
    You need to delete all files with the following TWO exceptions: lock (file) and partial (directory).
    Once the files are deleted, re-open Cydia.
    Cydia will then re-download all of the Release files from the various repositories
    When it says "reloading data", Cydia is resolving the packages from the repositories with the underlying package manager (apt)
    After this step is performed, your package cache will be consistent again
    So, how do we delete these files?

    The easiest way is to download the iFile package (if it shows up in Cydia). It's shareware and will let you use it for a limited time. I recommend you purchase it, because it's a great tool to have. Navigate the filesystem to the /var -> lib -> apt -> lists directory. Use the edit button in the upper right to allow you to select the files. Remember, do NOT select lock nor partial. Once the files are selected, tap the trash can icon in tab bar. Empty the trash. Fire up Cydia and get back to work."
     
  17. Mazda 3s macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #17
    I'm having this EXACT same problem. Was just getting ready to make a new post about it:
     

    Attached Files:

  18. v1nsai macrumors newbie

    Joined:
    Jul 21, 2012
    #18
    The same thing just happened to me for the first time, except ALL my Cydia apps are gone including Cydia. Just rebooted and they are still missing. I recently reset all my settings from inside Settings.app
     
  19. StinkyDonk macrumors regular

    Joined:
    Jan 2, 2012
    #19
    Same happened to me.

    I updated from OS5 to iOS 7.0.6 & then jailbroke. Everything was good for the first day or so.

    Then i got those cross white icons. Cydia was working but BytaFont2 & Barrel had those white cross icons instead & wouldn't open.

    They then disappeared.

    I went into Cydia to download them again but it said "modify" as though they were already installed. Except they weren't showing.

    Went for a reinstall & everything was fine.
     
  20. mrmike316 macrumors regular

    Joined:
    Jun 21, 2009
    #20
    I am having the same problem, tried doing this it works temporarily then after a while it goes back to the cross white icons...anyone know of a fix
     
  21. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #21
    I've got this going on, also. Anyone running any beta tweaks? I've been running the beta releases of Activator recently.
     
  22. hxfiz macrumors newbie

    Joined:
    Mar 9, 2014
    #22
    i'm currently having this problem too. i'm running iOS 7.0.6 on iPhone 5s. has anyone found a permanent fix yet?

    it's really annoying having to keep reinstalling an app from cydia every now and then.
     
  23. Synergie macrumors 6502a

    Joined:
    Jan 15, 2011
    Location:
    Halifax, Canada
    #23
    I have this same issue! I don't actually have very many JB apps installed... only a few. But iFile does that, and so does Springtomize...

    If I go to Cydia and reinstall they are back no problem. My fix for SPringtomize was to just hide the icon and launch from Settings instead. And since I don't use iFile too much, I just removed it and reinstall when I need it.

    But why is it even doing this??? Why do the icons turn into those white grid like thingies? And then when you try to open the app it just bumps back to springboard...
     
  24. Alain78, Mar 14, 2014
    Last edited: Mar 14, 2014

    Alain78 macrumors newbie

    Joined:
    Mar 14, 2014
    Location:
    Paris, France
    #24
    I had this problem too after jailbreaking my iPad 2 with Evasi0n 7 (under IOS 7.06). After rebooting my device, it was ok for some time but the problem came again quickly, randomly... Here is what I did:

    - with iFile, navigate to: /var/mobile/Library/Caches
    - delete the file: com.apple.mobile.installation.plist
    - reboot the device

    I did that some days ago and it seems the problem is fixed now :)
    Hope this helps!
     
  25. ClayMaster macrumors newbie

    Joined:
    Feb 7, 2008
    #25
    One cause for these apps disappearing - help needed from the experts

    i too had been plagued by these icons whiting out and then disappearing since upgrading to iOS 7.0.x (currently still seeing it on 7.0.6). I had configured a 2nd system (an iPad mini) and had a minimal installation for JB apps... only 2 tweaks were installed. Then one day the icons went white and disappeared on that device too.

    With only two tweaks installed on this 2nd device I worked closely with one of the tweak designers and we came to the conclusion that it was not the tweak.

    I started watching for a repeating pattern and looked for the various attributes that others had mentioned.

    What I saw was the JB Tweaks would white out during a WiFi iTunes sync. Using iTunes on a Mac 10.9.2 and the latest iTunes I had all my iOS devices configured to sync with WiFi. When adding or removing an app from the Apps Panel in iTunes and then WiFi syncing... the normally impacted tweaks would white out and then disappear after a reSpring. Even though Cydia still thought the tweak was installed you could not get to it as the icon was gone and spotlight could not see it.

    Interesting observation is that doing a WiFi iTunes sync just to move data does not change any tweak icons... you have to add or remove an app for the fault to occur. Also adding or removing apps via iTunes where the sync is done via USB cable do NOT create any faults.

    Consistent with others in this thread any app that whited out and disappeared on re-spring could be recovered by re-installing ANY JB tweak. Re-installing an un-related tweak would make the impacted tweak re-appear and everything was normal after that until the next WiFi iTunes sync... the pattern would repeat every time.

    Root cause for this behavior is not known... only the pattern. I encourage others to see if this pattern causes their problem to repeat and hopefully we will get the attention of some of the core JB contributors.
     

Share This Page