Cydia broken?

Discussion in 'iPad Hacks' started by Theraker007, Nov 5, 2010.

  1. Theraker007 macrumors regular

    Joined:
    Mar 3, 2009
    #1
    Everytime I try to open cydia it closes out on me immediately. I tried rebooting my iPad to no avail. Am I gonna have to wipe and reinstall or is there another way?
     
  2. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #2
    If you are handy with Terminal or SSH you can try this command:

    dpkg --configure -a

    I was having the same issues yesterday and this cleaned it up for me. If you are not familiar with terminal, don't do it :)
     
  3. JSalig, Nov 5, 2010
    Last edited: Nov 5, 2010

    JSalig macrumors 6502

    Joined:
    Oct 30, 2010
    #3
    This kept happening to me yesterday. Using ifile I went into the var/lib/dpkg/updates folder and deleted all files inside it. After that cydia stopped crashing. However, it may not be a permanent solution. The problem seems to reoccur when I reboot my ipad.
     
  4. mcarthon macrumors regular

    Joined:
    Jun 18, 2010
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    Sweet man this worked for me but after each reboot the files come back and you have to delete them again. I'm going o use this fix until I restore for 4.2 jailbreak
     
  5. Armeniandave macrumors 6502

    Joined:
    Jun 12, 2010
    Location:
    San Diego
    #5
    Having the same problem but theres no dpkg folder??
     
  6. JSalig macrumors 6502

    Joined:
    Oct 30, 2010
    #6
    Sorry. I meant the var/lib/dpkg/updates folder. Not var/mobile.
     
  7. Theraker007 thread starter macrumors regular

    Joined:
    Mar 3, 2009
    #8
    I'm not on 4.2. Also I don't have ifile installed so I cant. Get to it on cydia. And for some reason i can't seem to get into my iPad with cyberduck. I s ee shh on my sbsettings so it should be installed.

    If i restore my iPad and rejailbreak would I lose my saved game states for my games? What about if I got one not from the iTunes store?
     

Share This Page