Cydia Crash, iFunBox with or without OpenSSH?

Discussion in 'Jailbreaks and iOS Hacks' started by jtwestie, Nov 24, 2011.

  1. jtwestie macrumors newbie

    Joined:
    Nov 24, 2011
    #1
    Hi guys,

    I was in the position that I had 4.2.1 on an iPhone 3G, jailbroken and unlocked with Ultrasn0w. See this thread. http://forums.macrumors.com/showthread.php?t=1093384

    Downgraded back to 3.1.3 for speed, battery etc - except I cannot open Cydia anymore, it just crashes immediately.

    Obviously I cannot just install Icy, or Rock, OpenSSH etc because I cannot open Cydia.

    I've connected my iPhone to my Windows laptop (everything else done on iMac, OS X Lion) using iFunBox to delete the said files in var/lib/.

    Question is; do I need OpenSSH installed to allow me to view the files to delete in iFunBox, as there don't seem to be any more than should already be there.

    If so, how do I install OpenSSH without a correctly functioning Cydia? I've rejailbroken twice already, using Redsn0w.

    I look forward to your replies! :D
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Why dont you just restore to 3.1.3 and rejailbreak it.
    Way easier than jumping thru 100 hoops.
     
  3. jtwestie thread starter macrumors newbie

    Joined:
    Nov 24, 2011
    #3
    That's exactly what I've done - Restored back and re Jailbroken. So I am currently Jailbroken on 3.1.3, but I cannot open Cydia as it just crashes immediately.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    So do it again.
    Restore to 3.1.3 and rejailbreak.
    Something must have went wrong the first time.
     
  5. jtwestie thread starter macrumors newbie

    Joined:
    Nov 24, 2011
    #5
    4th re Jailbreak has just finished - Cydia still crashes.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Weird, what are you using to JB?
    Try a different program.
    I know there is redsnow, spirit, blackrain, not sure if JBme.com would do it also.
     
  7. jtwestie, Nov 24, 2011
    Last edited: Nov 24, 2011

    jtwestie thread starter macrumors newbie

    Joined:
    Nov 24, 2011
    #7
    Using redsn0w 0.9.4.

    Restored to 3.1.2_7D11, then jailbroke with the 3.1.3_7E17 IPSW as to be able to go back to 3.1.3 with 6.15 BB

    EDIT: Will try Spirit now
     
  8. jtwestie, Nov 24, 2011
    Last edited: Nov 24, 2011

    jtwestie thread starter macrumors newbie

    Joined:
    Nov 24, 2011
    #8
    Jailbroken with Spirit - Cydia now loads! :D Thank you so much! Obviously no custom boot logo anymore - but that's hardly an issue.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Glad it worked out.
    I had the same type of issue yesterday using redsnow to JB an i4 on 4.2.1
    Cydia would just open and close right away. I used Greenpoison and went fine after that.
     
  10. jtwestie thread starter macrumors newbie

    Joined:
    Nov 24, 2011
    #10
    Still not quite right - after installing anything with Cydia, then pressing 'Restart Springboard', the phone just hangs on a blank screen with a loading wheel forcing me to reboot.

    However, respringing with SBSettings causes no problems at all. Any ideas?
     

Share This Page