Cydia crashed while downloading, acting strange, any ideas?

Discussion in 'Jailbreaks and iOS Hacks' started by dwalk52, Sep 13, 2009.

  1. dwalk52 macrumors newbie

    Joined:
    Aug 9, 2008
    #1
    Hello all. So I was downloading Ad-blocker I think it was, and in the middle of the download my iPhone 3G's screen flashed white briefly and then rebooted. Following that, Cydia will open for a moment, before closing back to the home screen, and nothing seems to fix it. One helpful commenter suggested using the apt-get remove cydia command, followed by a apt-get install cydia or something like that, but upon typing in the command, I get the following popup in WinSCP, "The following package needs to be reinstalled. but I can't find an archive for it..."
    Here's a pic:
    [​IMG]
    or here:
    http://farm3.static.flickr.com/2576/3916914681_bec8d4c373_o.png
    Yes I am using WinSCP on a Mac, through Crossover, but trust me thats not causing the problem because I tried it on a windows comp as well and got the same error.

    All in all I'm asking if anyone knows how I can fix this other than a fresh hard reset. Any help and suggestions are welcome and appreciated.
    Thanks
     
  2. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #2
    Ohkay... Firstly... Don't use WinSCP on a mac. A mac is built on Unix and has it's own native command prompt.

    Open Terminal and ssh to the phone as root.
    try
    Code:
    apt-get update
    After this you can try to remove and re-install cydia and the adblocker.
     

Share This Page