Cydia Crashes and won't Open

Discussion in 'Jailbreaks and iOS Hacks' started by EatMyApple, Jul 10, 2009.

  1. EatMyApple macrumors 6502

    Dec 2, 2008
    Last night I jailbroke, and a few bumps in the road but its coming along. Pretty much have a small clue as to what I am doing but I'm learning.

    Cydia was working fine and I used it to get LockInfo. But now, I can not get Cydia to open. I click on it, it brings up the window and then closes itself. I have done a turn off/turn on and a hard restart - and it will still not open.

    Can I use the Freeze program to re-install Cydia, or will that cause a problem?

    Thought I would double check here before I really screwed something up. Thank you!
  2. EatMyApple thread starter macrumors 6502

    Dec 2, 2008
    OK well I went ahead and reinstalled Cydia from the Freeze program. It still opens up, black screen, then closes itself out.

    Any ideas how I can get Cydia to open and function?
  3. TSX macrumors 68030


    Oct 1, 2008
  4. EatMyApple thread starter macrumors 6502

    Dec 2, 2008
    Replied to this post in other thread - but have tried that. No luck!
  5. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    When you JB, did you install Icy & Cydia both ?

    If so, many are reporting the same problems as you.

    Re-JB and only add Cydia, not Icy.

    Might fix it.
  6. EatMyApple thread starter macrumors 6502

    Dec 2, 2008
    I did not install or download Icy. Not even sure what it is really other than what I have read that its similar or better than Cydia.

    I only installed Cydia from Freeze, updated the Cydia, downloaded Winterboard, and only got to add LockInfo. After one of the restarts I was never able to get Cydia to open fully.

    I guess I will try a Restore and Re-JB tomorrow.
  7. Aries326 macrumors 6502

    Dec 28, 2007
    I had the same problem as you. I have a 3G. I had to restore my phone, re-jailbreak but this time, in Cydia, I did not install the essential upgrade. I noticed last time Cydia would freeze/reset after I installed the essential upgrade. I have no clue what the essential upgrade does so I just left it out this time and everything seems to be working fine.
  8. EatMyApple thread starter macrumors 6502

    Dec 2, 2008
    Ahhhhh I think I will try that - Thanks for the post! My Cydia froze up also pretty soon after the update. I am about to restore also so I'm glad you posted and I read this before. Thanks again!
  9. foob macrumors 6502


    Feb 17, 2009
    My Cydia was crashing every time it opened. I traced it to corrupt files in /var/lib/dpkg/updates. Deleting them fixed Cydia. I can't guarantee that will fix Cydia crashes but it has worked for several people who have asked the same question here recently.

    Here are a few methods to delete them.

    SSH into the phone and type "rm /var/lib/dpkg/updates/*" (without quotes) and hit enter.

    Open MobileTerminal on the phone and type "rm /var/lib/dpkg/updates/*" (without quotes) and hit enter.

    Use the apps iFile or Discover from Cydia to browse to /var/lib/dpkg/updates/ and swipe the files then select delete, or in iFile select edit, check all the files, then tap the trash can at the bottom.
  10. iMrNiceGuy0023 macrumors 68000

    Jun 5, 2009
    delet the whole "updates" folder??
  11. EatMyApple thread starter macrumors 6502

    Dec 2, 2008
    How do you open MobileTerminal? I'm guessing that should have been downloaded from Cydia before it crashed? Thanks!
  12. Aries326 macrumors 6502

    Dec 28, 2007
    So, after reading another thread similar to this, it seems the real problem lies with installing a package and an error pops up and the installation is not completed. To test this out, I did upgrade the files in Cydia and this time, everything installed perfectly and Cydia still runs perfectly.

    As the other thread pointed out, you'll have to download a program or use the terminal in the iphone and search out the folder where files are installed. There, you'll find some files numbered in sequence. Delete those and problems are solved.

    Here's the info from the thread I am referring to:

    Here's the thread for more info:
  13. iMrNiceGuy0023 macrumors 68000

    Jun 5, 2009
    this method worked
  14. sslanchi macrumors regular


    Nov 21, 2008
    Following these instructions worked for me also..thank you!!!

    Its worth noting that the program iPhoneBrowser is much easier to use than SSH'ing
  15. nada1985 macrumors newbie

    Sep 23, 2009
    Cydia wont open and I can't restore my iphone.

    i've jailbroken my iphone 3.0.1 using redsnow to install cydia. After using it for a day cydia would open and the close. I tried to re-install cydia but it still wouldnt open, so i tried to restore the phone to its original setting but itunes came up with error message 2 cannot restore iphone. Now im stuck with an annoyingly slow phone. I've read alot about people deleting corrupt files by ssh in to their iphones. I never installed ssh through cydia, so i cant figure out how to do this. any ideas????I also downloaded icy and tried to install openssh that way but it wouldnt download fully! I really have a basic knowledge of how this all works, so if somebody could give me some simple steps to fix this i would greatly appreciate it!!
  16. Narco220 macrumors regular

    Nov 27, 2008
    I am having the same problem with cydia but when i ssh into the rm /var/lib/dpkg/updates/ folder its empty so theres nothing to delete to fix the problem??
  17. macrumors regular

    Dec 6, 2003

    Do you mean all the files only in the updates folder? I get all the way to there and there are none.

    But there are files in dpkg
  18. rocpatel macrumors newbie

    Nov 17, 2009
    Try starting Cydia in Safe Mode. Use SBsettings to start in Safe Mode. The problem was with a mobile substrate app. Uninstalling Cyntacts and Rotate Inhibitor did the trick.

    Hope this helps.
  19. ChrisR24 macrumors newbie

    Apr 27, 2009
    saMe problem with me. I've had the 3.0 jailbreak since it came out, with no
    problems. I never had icy. Now, I tried to open cydia for the first time this month, won't work. /dpkg/updates is empty. Earlier today I was playin around with ifile, tryin to get mxtube vids into the phtos folder (I don't know why) but maybe this has something to do with it. Let me know if you find anything.

  20. Vegastouch macrumors 603


    Jul 12, 2008
    Las Vegas, NV
    Awesome! I just got a lockscreen from cydia and after that it wouldnt open anymore. I have iFile and saw this and deleted my updates and Cydia works again. :D
  21. snatch24 macrumors newbie

    Jan 14, 2010
    Presto, still works a year after the original post. Thanks.
  22. mgmusicman94 macrumors 6502a

    Nov 16, 2008
    Worked for me using iFile. Thank you sooooo much.
  23. Flysaiah macrumors newbie

    Feb 18, 2010
    Ok so I am new to jailbreaking...but i managed to do it myself i have an iphone 3G jailbroken and unlocked on 3.1.2. and my Cydia keeps crashing as well.

    I would like to try one of the methods posted here but i have no idea what SSH even means....someone help the noob please!
  24. Vegastouch macrumors 603


    Jul 12, 2008
    Las Vegas, NV
    If you read all of this then I think it is obvious that the iFile method is much easier and you don't need to know what SSH means.
  25. Flysaiah macrumors newbie

    Feb 18, 2010
    ok so i dont know what the hell ifile is stated earlier i am a noob to i download ifile from cydia? because if thats the case i never did and cydia keeps crashing..can i get it from somewhere else?

Share This Page