Cydia Crashing

Discussion in 'Jailbreaks and iOS Hacks' started by hotnts, May 26, 2010.

  1. hotnts macrumors member

    Joined:
    Mar 26, 2009
    #1
    My phone is jailbroken with spirit. It has been for about a week or so and i love it. I recently tried to install rock on my phone and about halfway through the install my phone just rebooted. After that cydia opens to the reloading screen then it crashes. I have resprung, rebooted many times and still the same result. Every other app runs fine, it seems that cydia somehow was messed up during the failed install. Would anybody have any incite on how to fix this? Without restoring:rolleyes: Thanks in advance to any help you could give!
     
  2. trublu304 macrumors newbie

    Joined:
    Dec 8, 2009
    #2
  3. hotnts thread starter macrumors member

    Joined:
    Mar 26, 2009
    #3

    i guess my only problem would be downloading iFile or open ssh. How do i do this considering cydia does not work? I do have installous for try before buy purposes but thats it. it there another way to get something to delete the update file?
     
  4. hotnts thread starter macrumors member

    Joined:
    Mar 26, 2009
    #4
    any help would be appreciated:confused:
     
  5. IndianBird macrumors 6502a

    Joined:
    Dec 28, 2009
    #5
    Did you not already have SSH on your phone?

    It's a staple of jailbreaking. If you have it, just turn it on in your SBSettings(another staple) then download iPhone Browser, or WinSCP3, or any of the file browsers available.

    Then go to the directory mentioned above and delete all the updates from that file, and you should be good to go.

    If you don't have any SSH capabilities, you are looking at a restore and rejailbreak.
     
  6. hotnts thread starter macrumors member

    Joined:
    Mar 26, 2009
    #6

    Are there any App store Apps that have the same ability as openssh? I saw a few in the app store to purchase, would something like that work?
     
  7. IndianBird macrumors 6502a

    Joined:
    Dec 28, 2009
    #7
    i do not believe that will work, but i could be mistaken

    as tight is Apple is about keeping things closed source, I don't think such an app would exist in their app store
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    Since OpenSSH file transfer is locked out on non jailbroken phones, I doubt such a utility is available in the App Store.
     
  9. almostaskater62 macrumors regular

    Joined:
    Nov 15, 2007
    #9
    this was happening to me and i deleted everything in var/lib/apt/lists and it fixed cydia but now i have no sources and no packages...
    so the only way to uninstall stuff would be to restore right?
     

Share This Page